lkml.org 
[lkml]   [2022]   [Sep]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRE: [PATCH 03/15] cxl: Unify debug messages when calling devm_cxl_add_port()
Robert Richter wrote:
> CXL ports are added in a couple of code paths using
> devm_cxl_add_port(). Debug messages are individually generated, but
> are incomplete and inconsistent. Change this by moving its generation
> to devm_cxl_add_port(). This unifies the messages and reduces code
> duplication. Also, generate messages on failure.
>
> Signed-off-by: Robert Richter <rrichter@amd.com>
> ---
> drivers/cxl/acpi.c | 2 --
> drivers/cxl/core/port.c | 39 ++++++++++++++++++++++++++++-----------
> 2 files changed, 28 insertions(+), 13 deletions(-)
>
> diff --git a/drivers/cxl/acpi.c b/drivers/cxl/acpi.c
> index fb649683dd3a..767a91f44221 100644
> --- a/drivers/cxl/acpi.c
> +++ b/drivers/cxl/acpi.c
> @@ -220,7 +220,6 @@ static int add_host_bridge_uport(struct device *match, void *arg)
> port = devm_cxl_add_port(host, match, dport->component_reg_phys, dport);
> if (IS_ERR(port))
> return PTR_ERR(port);
> - dev_dbg(host, "%s: add: %s\n", dev_name(match), dev_name(&port->dev));
>
> return 0;
> }
> @@ -466,7 +465,6 @@ static int cxl_acpi_probe(struct platform_device *pdev)
> root_port = devm_cxl_add_port(host, host, CXL_RESOURCE_NONE, NULL);
> if (IS_ERR(root_port))
> return PTR_ERR(root_port);
> - dev_dbg(host, "add: %s\n", dev_name(&root_port->dev));
>
> rc = bus_for_each_dev(adev->dev.bus, NULL, root_port,
> add_host_bridge_dport);
> diff --git a/drivers/cxl/core/port.c b/drivers/cxl/core/port.c
> index bffde862de0b..8604cda88787 100644
> --- a/drivers/cxl/core/port.c
> +++ b/drivers/cxl/core/port.c
> @@ -666,13 +666,17 @@ struct cxl_port *devm_cxl_add_port(struct device *host, struct device *uport,
> resource_size_t component_reg_phys,
> struct cxl_dport *parent_dport)
> {
> - struct cxl_port *port;
> + struct cxl_port *port, *parent_port;
> struct device *dev;
> int rc;
>
> + parent_port = parent_dport ? parent_dport->port : NULL;
> +
> port = cxl_port_alloc(uport, component_reg_phys, parent_dport);
> - if (IS_ERR(port))
> - return port;
> + if (IS_ERR(port)) {
> + rc = PTR_ERR(port);
> + goto err_out;

While I agree this unifies the error messaging I am not a fan of what
this does to the readability of the error exits. What about a compromise
of renaming devm_cxl_add_port to __devm_cxl_add_port() and add back a
new devm_cxl_add_port that does the unified debug messaging?

\
 
 \ /
  Last update: 2022-09-08 07:53    [W:1.232 / U:0.068 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site