lkml.org 
[lkml]   [2019]   [Feb]   [26]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subject[PATCH 0/14] v2 multi-die/package topology support
Date
This patch series does 4 things.

1. Parses the new CPUID.1F leaf to discover multi-die/package topology

2. Export multi-die topology inside the kernel

3. Update 3 places (coretemp, pkgtemp, rapl) that that need to know
the difference between die and package-scope MSR.

(Note: Kan Liang has a patch series on top of this one to similarly
make the uncore perf code multi-die/package aware.)

4. Export multi-die topology to user-space via sysfs

These changes should have 0 impact on cache topology,
NUMA topology, Linux scheduler, or system performance.

These topology changes primarily impact parts of the kernel
and some applciations that care about package MSR scope.
Also, some software is licensed per package, and other tools,
such as benchmark reporting software sometimes cares about packages.

Changes since v1:

Responded to all syntax and style feedback.

Fixed a bug in the CPUID.1F parsing code
we were parsing the leaf properly, but in some configs
we were not updating the maps correctly

topology_logical_die_id() replaces topology_unique_die_id()

Suggested by Kan, who's uncore code uses
topology_logical_package_id().

Restored sysfs core_siblings, core_siblings_list

v1 proposed re-defining this existing attribute to
be the threads in a die, rather than in a package.

For compatibility, decided rather to keep this
attribute unchanged, for now, even though
its name makes little sense, and it makes
no sense in a multi-die system.

Added sysfs package_threads, package_threads_list

Added this attribute to show threads siblings in a package.
Exactly same as "core_siblings above", a name now deprecated.
This attribute name and definition is immune to future
topology changes.

Suggested by Brice.

Added sysfs die_threads, die_threads_list

Added this attribute to show which threads siblings in a die.
V1 had proposed putting this info into "core_siblings", but we
decided to leave that legacy attribute alone.
This attribute name and definition is immune to future
topology changes.

On a single die-package system this attribute has same contents
as "package_threads".

Suggested by Brice.

Added sysfs core_threads, core_threads_list

Added this attribute to show which threads siblings in a core.
Exactly same as "thread_siblings", a name now deprecated.
This attribute name and definition is immune to future
topology changes.

Suggested by Brice.


For compatibility, sysfs cpuX/topology core_siblings
and core_siblings_list are unchanged. They retain
their legacy defintion of listing which CPUs share
the same package.

Patch Summary:

Unchanged:

[PATCH 01/14] x86 topology: Fix doc typo
[PATCH 02/14] topolgy: Simplify cputopology.txt formatting and
[PATCH 03/14] x86 smpboot: Rename match_die() to match_pkg()
[PATCH 05/14] cpu topology: Export die_id
[PATCH 07/14] powercap/intel_rapl: Simplify rapl_find_package()
[PATCH 10/14] powercap/intel_rapl: update rapl domain name and debug

Bug Fixed:

[PATCH 04/14] x86 topology: Add CPUID.1F multi-die/package support

New since v1:

[PATCH 06/14] x86 topology: Define topology_logical_die_id()
[PATCH 12/14] topology: Create package_threads sysfs attribute
[PATCH 13/14] topology: Create core_threads sysfs attribute
[PATCH 14/14] topology: Create die_threads sysfs attribute

Updated (to use logical_die_id()):

[PATCH 08/14] powercap/intel_rapl: Support multi-die/package
[PATCH 09/14] thermal/x86_pkg_temp_thermal: Support multi-die/package
[PATCH 11/14] hwmon/coretemp: Support multi-die/package



Documentation/cputopology.txt | 72 ++++++++++++++---------
Documentation/x86/topology.txt | 6 +-
arch/x86/include/asm/processor.h | 5 +-
arch/x86/include/asm/smp.h | 1 +
arch/x86/include/asm/topology.h | 5 ++
arch/x86/kernel/cpu/topology.c | 85 +++++++++++++++++++++-------
arch/x86/kernel/smpboot.c | 73 +++++++++++++++++++++++-
arch/x86/xen/smp_pv.c | 1 +
drivers/base/topology.c | 22 +++++++
drivers/hwmon/coretemp.c | 9 +--
drivers/powercap/intel_rapl.c | 75 +++++++++++++-----------
drivers/thermal/intel/x86_pkg_temp_thermal.c | 9 +--
include/linux/topology.h | 6 ++
13 files changed, 276 insertions(+), 93 deletions(-)

These patches are also available in the Git repository at:

git://git.kernel.org/pub/scm/linux/kernel/git/lenb/linux.git x86


\
 
 \ /
  Last update: 2019-02-26 07:20    [W:0.219 / U:2.680 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site