lkml.org 
[lkml]   [2022]   [Apr]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [PATCH v1 3/3] dt-bindings: iio: accel: add dt-binding schema for msa311 accel driver
Date
Hello Jonathan,

Thank you for the quick feedback.
I completely agree with all of your comments. Please find my notes below.

On Wed, Apr 20, 2022 at 09:51:27AM +0100, Jonathan Cameron wrote:
> On Tue, 19 Apr 2022 15:45:58 +0000
> Rokosov Dmitry Dmitrievich <DDRokosov@sberdevices.ru> wrote:
>
> > Introduce devicetree binding json-schema for MSA311 tri-axial,
> > low-g accelerometer driver.
> >
> > Signed-off-by: Dmitry Rokosov <ddrokosov@sberdevices.ru>
> Hi Dmitry and welcome to IIO.
>
> Sign off generally matches the From: of the email.
> Makes it easier for scripts to check than having different name forms.
>

Yes, looks like this problem is located on the corporative Exchange server side.
I use DavMail local proxy to send emails, so server changes From: statement.
I have already discussed it with our IT guys, it should be fixed starting from current email.

> > ---
> > .../bindings/iio/accel/memsensing,msa311.yaml | 64 ++++++++++++++++++++++
> > MAINTAINERS | 1 +
> > 2 files changed, 65 insertions(+)
> > create mode 100644 Documentation/devicetree/bindings/iio/accel/memsensing,msa311.yaml
> >
> > diff --git a/Documentation/devicetree/bindings/iio/accel/memsensing,msa311.yaml b/Documentation/devicetree/bindings/iio/accel/memsensing,msa311.yaml
> > new file mode 100644
> > index 00000000..3e4660f
> > --- /dev/null
> > +++ b/Documentation/devicetree/bindings/iio/accel/memsensing,msa311.yaml
> > @@ -0,0 +1,64 @@
> > +# SPDX-License-Identifier: GPL-2.0-only OR BSD-2-Clause
> > +
> > +%YAML 1.2
> > +---
> > +$id: "http://devicetree.org/schemas/iio/accel/memsensing,msa311.yaml#"
> > +$schema: "http://devicetree.org/meta-schemas/core.yaml#"
> > +
> > +title: MEMSensing digital 3-Axis accelerometer
> > +
> > +maintainers:
> > + - Dmitry Rokosov <ddrokosov@sberdevices.ru>
> > +
> > +description: |
> > + MSA311 is a tri-axial, low-g accelerometer with I2C digital output for
> > + sensitivity consumer applications. It has dynamical user selectable full
> > + scales range of +-2g/+-4g/+-8g/+-16g and allows acceleration measurements
> > + with output data rates from 1Hz to 1000Hz.
> > + Datasheet can be found at following URL
> > + https://cdn-shop.adafruit.com/product-files/5309/MSA311-V1.1-ENG.pdf
> > +
> > +properties:
> > + compatible:
> > + const: memsensing,msa311
> > +
> > + "#address-cells":
> > + const: 1
> > +
> > + "#size-cells":
> > + const: 0
> > +
> > + reg:
> > + maxItems: 1
> > + description: I2C registers address
> > +
> > + interrupts:
> > + maxItems: 1
> > + description: optional I2C int pin can be freely mapped to specific func
> > +
> > + interrupt-names:
> > + const: irq
>
> For a single IRQ giving it a name isn't that useful so I would drop this.
>
>

Based on Documentation/devicetree/bindings/example-schema.yaml I thought
interrupt-names must contain irq name regardless of interrupt count,
because it helps to understand right property name.
I'll delete it for v2.

> > +
> > +required:
> > + - compatible
> > + - reg
> > +
> > +additionalProperties: false
> > +
> > +examples:
> > + - |
> > + #include <dt-bindings/gpio/gpio.h>
>
> Why have this?
>

I agree, this header is needed for GPIO constant values, which is not used here.
I'll remove it for the v2 then.

> > + #include <dt-bindings/interrupt-controller/irq.h>
> > + i2c0 {
> > + #address-cells = <1>;
> > + #size-cells = <0>;
> > +
> > + msa311: msa311@62 {
> Generic naming required.
> accelerometer@62 {
>

Okay, I will change it in the next version.

> > + compatible = "memsensing,msa311";
> > + reg = <0x62>;
> > + interrupt-parent = <&gpio_intc>;
> > + interrupts = <29 IRQ_TYPE_LEVEL_HIGH>;
> > + interrupt-names = "irq";
> > + status = "okay";
>
> We don't often have status in the examples.
>

Sure, status is useful for real dts declarations.
It's there because I copied this declaration from by tested real board dts :-)

>
> Otherwise looks good to me.
>
> Thanks,
>
> Jonathan
>
> > + };
> > + };
> > diff --git a/MAINTAINERS b/MAINTAINERS
> > index c75be17..4227914 100644
> > --- a/MAINTAINERS
> > +++ b/MAINTAINERS
> > @@ -12482,6 +12482,7 @@ MEMSENSING MICROSYSTEMS MSA311 ACCELEROMETER DRIVER
> > M: Dmitry Rokosov <ddrokosov@sberdevices.ru>
> > L: linux-iio@vger.kernel.org
> > S: Maintained
> > +F: Documentation/devicetree/bindings/iio/accel/memsensing,msa311.yaml
> > F: drivers/iio/accel/msa311.c
> >
> > MEN A21 WATCHDOG DRIVER
>

--
Thank you,
Dmitry
\
 
 \ /
  Last update: 2022-04-21 15:56    [W:0.108 / U:0.376 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site