lkml.org 
[lkml]   [2021]   [Dec]   [16]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [PATCH 1/1] riscv: default to CONFIG_RISCV_SBI_V01=n
From
On 12/16/21 14:49, Jessica Clarke wrote:
> On 16 Dec 2021, at 12:35, Heinrich Schuchardt <heinrich.schuchardt@canonical.com> wrote:
>>
>> The SBI 0.1 specification is obsolete. The current version is 0.3.
>> Hence we should not rely by default on SBI 0.1 being implemented.
>
> It’s what BBL implements, and some people are still using it,
> especially given early hardware shipped before OpenSBI grew in
> popularity.
>
> Jess
>

Do you mean BBL is not developed anymore?

Some people may still be using a 0.1 SBI. But that minority stuck on an
outdated software stack does not justify defaulting to deprecated
settings in future Linux releases.

Best regards

Heinrich

\
 
 \ /
  Last update: 2021-12-16 15:19    [W:0.103 / U:0.016 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site