lkml.org 
[lkml]   [2013]   [Jan]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 01/17] mm/compaction: rename var zone_end_pfn to avoid conflicts with new function
On 01/15/2013 04:24 PM, Cody P Schafer wrote:
> Patches that follow add a inline function zone_end_pfn(), which
> conflicts with the naming of a local variable in isolate_freepages().
>
> Rename the variable so it does not conflict.

It's probably worth a note here that you _will_ be migrating this use
over to the new function anyway.

> @@ -706,7 +706,7 @@ static void isolate_freepages(struct zone *zone,
> * only scans within a pageblock
> */
> end_pfn = ALIGN(pfn + 1, pageblock_nr_pages);
> - end_pfn = min(end_pfn, zone_end_pfn);
> + end_pfn = min(end_pfn, z_end_pfn);

Is there any reason not to just completely get rid of z_end_pfn (in the
later patches after you introduce zone_end_pfn() of course):

> + end_pfn = min(end_pfn, zone_end_pfn(zone));

I wouldn't be completely opposed to you just introducing zone_end_pfn()
and doing all the replacements in a single patch. It would make it
somewhat easier to review, and it would also save the juggling you have
to do with this one.



\
 
 \ /
  Last update: 2013-01-16 02:21    [W:0.179 / U:0.440 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site