lkml.org 
[lkml]   [2013]   [Jan]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 02/17] mmzone: add various zone_*() helper functions.
On 01/15/2013 04:24 PM, Cody P Schafer wrote:
> +static inline bool zone_spans_pfn(const struct zone *zone, unsigned long pfn)
> +{
> + return zone->zone_start_pfn <= pfn && pfn < zone_end_pfn(zone);
> +}

This needs some parenthesis, just for readability. There's also no
crime in breaking it up to be multi-line if you want.

> +static inline bool zone_is_initialized(struct zone *zone)
> +{
> + return !!zone->wait_table;
> +}
> +
> +static inline bool zone_is_empty(struct zone *zone)
> +{
> + return zone->spanned_pages == 0;
> +}





\
 
 \ /
  Last update: 2013-01-16 03:02    [W:0.145 / U:0.364 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site