[lkml]   [2012]   [Dec]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: dire state of rtl driver in 3.7
On Sun, Dec 23, 2012 at 06:49:55AM +0100, Mike Galbraith wrote:
> Looks a lot like my driver experience with older kernels, I had to use
> the external driver in the rare event that I needed wireless to work.
> The in tree driver works peachy these days (needed it recently, was
> pleasantly surprised when it _just worked_, not even a hiccup), so
> somebody cared, gave at least the 10ec:8181 bits some serious love.

Good for you.

I have a [10ec:8176] in my laptop and while I don't have the issues
Norbert is reporting, I can't say the thing just worked.

I had to use the wireless recently in a bunch of networks and what it
would do, is associate properly, connection gets established and traffic
is fine for a minute or so. Then, after a minute traffic would cease and
I'd need to re-associate. And it worked sporadically, sometimes fine,
sometimes with constant connection interruptions. And this observation
was the case with almost all wireless networks I'd use.

FWIW, the wifi adapter is:

01:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter [10ec:8176] (rev 01)
Subsystem: Realtek Semiconductor Co., Ltd. Device [10ec:8195]
Flags: fast devsel, IRQ 17
I/O ports at 3000 [size=256]
Memory at f0200000 (64-bit, non-prefetchable) [size=16K]
Capabilities: [40] Power Management version 3
Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit+
Capabilities: [70] Express Endpoint, MSI 00
Capabilities: [100] Advanced Error Reporting
Capabilities: [140] Virtual Channel
Capabilities: [160] Device Serial Number 01-91-81-fe-ff-4c-e0-00

using rtl8192ce.



Sent from a fat crate under my desk. Formatting is fine.

 \ /
  Last update: 2012-12-23 14:41    [W:0.085 / U:5.980 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site