lkml.org 
[lkml]   [2023]   [Sep]   [18]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [RFC PATCH v2 13/35] ACPI: Rename acpi_scan_device_not_present() to be about enumeration
From


On 9/14/23 02:38, James Morse wrote:
> acpi_scan_device_not_present() is called when a device in the
> hierarchy is not available for enumeration. Historically enumeration
> was only based on whether the device was present.
>
> To add support for only enumerating devices that are both present
> and enabled, this helper should be renamed. It was only ever about
> enumeration, rename it acpi_scan_device_not_enumerated().
>
> No change in behaviour is intended.
>
> Signed-off-by: James Morse <james.morse@arm.com>
> ---
> drivers/acpi/scan.c | 8 ++++----
> 1 file changed, 4 insertions(+), 4 deletions(-)
>

Reviewed-by: Gavin Shan <gshan@redhat.com>

> diff --git a/drivers/acpi/scan.c b/drivers/acpi/scan.c
> index ed01e19514ef..17ab875a7d4e 100644
> --- a/drivers/acpi/scan.c
> +++ b/drivers/acpi/scan.c
> @@ -289,10 +289,10 @@ static int acpi_scan_hot_remove(struct acpi_device *device)
> return 0;
> }
>
> -static int acpi_scan_device_not_present(struct acpi_device *adev)
> +static int acpi_scan_device_not_enumerated(struct acpi_device *adev)
> {
> if (!acpi_device_enumerated(adev)) {
> - dev_warn(&adev->dev, "Still not present\n");
> + dev_warn(&adev->dev, "Still not enumerated\n");
> return -EALREADY;
> }
> acpi_bus_trim(adev);
> @@ -327,7 +327,7 @@ static int acpi_scan_device_check(struct acpi_device *adev)
> error = -ENODEV;
> }
> } else {
> - error = acpi_scan_device_not_present(adev);
> + error = acpi_scan_device_not_enumerated(adev);
> }
> return error;
> }
> @@ -339,7 +339,7 @@ static int acpi_scan_bus_check(struct acpi_device *adev, void *not_used)
>
> acpi_bus_get_status(adev);
> if (!acpi_device_is_present(adev)) {
> - acpi_scan_device_not_present(adev);
> + acpi_scan_device_not_enumerated(adev);
> return 0;
> }
> if (handler && handler->hotplug.scan_dependent)

Thanks,
Gavin

\
 
 \ /
  Last update: 2023-09-18 06:32    [W:0.998 / U:0.184 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site