lkml.org 
[lkml]   [2023]   [Feb]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subject[PATCH v2 0/4] rtw88: four small code-cleanups and refactorings
Date
Hello,

this series consists of four small patches which clean up and refactor
existing code in preparation for SDIO support. Functionality is
supposed to stay the same with these changes.

The goal of the first two patches is to make it easier to understand
the allowed values in the queue by using enum rtw_tx_queue_type instead
of u8.

The third patch in this series moves the rtw_tx_queue_type code out of
pci.c so it can be re-used by SDIO (and also USB) HCIs.

The last patch is another small cleanup to improve readability of the
code by using (already existing) macros instead of magic BIT(n).


Changes since v1 at [0]:
- add "wifi" to the subject of all patches
- add Ping-Ke's Acked-by to patches 2 and 4 (thank you!)
- add const keyword in patch 1
- add array bounds checking in patch 3
- remove references to another series from the cover letter as it's
not needed as a precondition / dependency anymore


[0] https://lore.kernel.org/netdev/20220114234825.110502-1-martin.blumenstingl@googlemail.com/


Martin Blumenstingl (4):
wifi: rtw88: pci: Use enum type for rtw_hw_queue_mapping() and
ac_to_hwq
wifi: rtw88: pci: Change queue datatype to enum rtw_tx_queue_type
wifi: rtw88: Move enum rtw_tx_queue_type mapping code to tx.{c,h}
wifi: rtw88: mac: Use existing macros in rtw_pwr_seq_parser()

drivers/net/wireless/realtek/rtw88/mac.c | 4 +-
drivers/net/wireless/realtek/rtw88/pci.c | 50 ++++++------------------
drivers/net/wireless/realtek/rtw88/tx.c | 41 +++++++++++++++++++
drivers/net/wireless/realtek/rtw88/tx.h | 3 ++
4 files changed, 57 insertions(+), 41 deletions(-)

--
2.39.1

\
 
 \ /
  Last update: 2023-03-27 00:10    [W:0.230 / U:0.868 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site