lkml.org 
[lkml]   [2023]   [Dec]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [PATCH v2 07/10] clk: qcom: Add dispcc clock driver for x1e80100
From
On 14/12/2023 16:49, Abel Vesa wrote:
> From: Rajendra Nayak <quic_rjendra@quicinc.com>
>
> Add the dispcc clock driver for x1e80100.
>
> Signed-off-by: Rajendra Nayak <quic_rjendra@quicinc.com>
> Reviewed-by: Dmitry Baryshkov <dmitry.baryshkov@linaro.org>
> Signed-off-by: Abel Vesa <abel.vesa@linaro.org>
> ---

> +static struct platform_driver disp_cc_x1e80100_driver = {
> + .probe = disp_cc_x1e80100_probe,
> + .driver = {
> + .name = "disp_cc-x1e80100",
> + .of_match_table = disp_cc_x1e80100_match_table,
> + },
> +};
> +
> +static int __init disp_cc_x1e80100_init(void)
> +{
> + return platform_driver_register(&disp_cc_x1e80100_driver);
> +}
> +subsys_initcall(disp_cc_x1e80100_init);
> +
> +static void __exit disp_cc_x1e80100_exit(void)
> +{
> + platform_driver_unregister(&disp_cc_x1e80100_driver);
> +}
> +module_exit(disp_cc_x1e80100_exit);
> +
> +MODULE_DESCRIPTION("QTI DISPCC X1E80100 Driver");
> +MODULE_LICENSE("GPL");
>

And we don't even do the odd underscore insertion consistently. For
whatever reason "DISPCC" instead of "DISP_CC"

Just to reiterate the underscores should be dropped from these clock
controller names and defines entirely, they just eat up bytes in databases.

.name = "dispcc-x1e80100"

("QTI DISPCC X1E80100 Driver"); better but IMO we could just a complete
word here

"Display Clock Controller" there's no need to abbreviate.

---
bod

\
 
 \ /
  Last update: 2023-12-15 13:45    [W:0.164 / U:0.592 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site