lkml.org 
[lkml]   [2023]   [Nov]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subject[PATCH v2 0/6] mm: cleanup and use more folio in page fault
Date
Rename page_copy_prealloc() to folio_prealloc(), which is used by
more functions, also do more folio conversion in page fault.

v2:
- add folio_test_large check in ksm_might_need_to_copy() and
replace page->index to folio->index, per David, Matthew
- Add RB of Sidhartha

Kefeng Wang (6):
mm: ksm: use more folio api in ksm_might_need_to_copy()
mm: memory: use a folio in validate_page_before_insert()
mm: memory: rename page_copy_prealloc() to folio_prealloc()
mm: memory: use a folio in do_cow_page()
mm: memory: use folio_prealloc() in wp_page_copy()
mm: memory: use folio_prealloc() in do_anonymous_page()

include/linux/ksm.h | 4 +--
mm/ksm.c | 39 ++++++++++++------------
mm/memory.c | 72 +++++++++++++++++++--------------------------
3 files changed, 53 insertions(+), 62 deletions(-)

--
2.27.0

\
 
 \ /
  Last update: 2023-11-20 13:58    [W:0.049 / U:0.280 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site