lkml.org 
[lkml]   [2023]   [Jan]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subject[PATCHv5 00/10] Introduce RK806 Support
Date
Hi,

The Rockchip RK3588 Evaluation Boards use SPI connected RK806
PMICs. Downstream this is handled by a new driver, but apart
from being SPI connected this chip is quite similar to the
ther Rockchip PMICs (also RK806 is promoted to also support
I2C). Thus this series instead updates the RK808 driver(s).

Changelog since PATCHv4:
* https://lore.kernel.org/all/20221020204251.108565-1-sebastian.reichel@collabora.com/
* rebase to v6.2-rc1
- dropped 'regulator: rk808: reduce 'struct rk808' usage' (queued to 6.2-rc1)
- dropped 'regulator: rk808: Use dev_err_probe' (queued to 6.2-rc1)
- dropped 'rtc: rk808: reduce 'struct rk808' usage' (queued to 6.2-rc1)
* use 'MFD_RK8XX' for the MFD driver supporting all the MFD8XX chips
* added author tags to drivers/mfd/rk8xx-core.c. They were missing because
I moved the original header over to the i2c specific file and wrote the
new header from scratch. I suppose it's better to have the author tags
in both files.
* fix Rob's comments for the rk806 YAML binding
* add defines for rk806 command indexes
* modify rk806 code, so that it is capable of mult-write

Changelog since PATCHv3:
* https://lore.kernel.org/all/20220909175522.179175-1-sebastian.reichel@collabora.com/
* Dropped removing REGMAP_I2C dependency from RK817 ASoC driver (applied)
* Rename MFD_RK808 to MFD_RK8XX to be consistent. It makes sense to do this now,
since the patchset touches all the child drivers anyways.
* rebase to v6.1-rc1
* collected a couple of Acks
* update rk806 DT binding according to DT maintainer feedback
* add missing pinmux config to the rk806 DT binding
* update rk806_spi_bus_write and rk806_spi_bus_read
* replaced some constants with sizeof or defines
* used capitalized comments
* rename regmap_find_closest_bigger to regulator_find_closest_bigger, not sure
why I prefixed it with regmap_ in the first place
* use rk8xx_is_enabled_wmsk_regmap instead of regulator_is_enabled_regmap for
the switching regulators to correctly report the state
* reordered the first few patches grouping the MFD patches together

Changelog since PATCHv2:
* https://lore.kernel.org/all/20220908003107.220143-1-sebastian.reichel@collabora.com/
* Change DT binding to not allow nldo-reg6
* Fix DT binding to check for [np]ldo-reg instead of [np]ldo_reg
* remove rk806_get_voltage_sel_regmap in favour of regulator_get_voltage_sel_regmap
* drop rk806_set_voltage in favour of regulator_set_voltage_sel_regmap
* use regulator_set_ramp_delay_regmap
* drop possibly incorrect printing of chip id register address in case of errors

Changelog since PATCHv1:
* https://lore.kernel.org/all/20220831215437.117880-1-sebastian.reichel@collabora.com/
* Collect Acked-by
* Avoid if/else checks for regulator id in rk806 regulator driver
* Fix indentation in DTS example section of the rk806 binding
* Use absolute path for regulator.yaml referencing in the rk806 binding
* Reduce pattern for DCDC regulators to only allow 1-10
* replace uppercase name with lowercase ones in regulator names
* replace _ with - in regulator names

-- Sebastian

Sebastian Reichel (10):
clk: RK808: reduce 'struct rk808' usage
mfd: rk808: convert to device managed resources
mfd: rk808: use dev_err_probe
mfd: rk808: replace 'struct i2c_client' with 'struct device'
mfd: rk808: split into core and i2c
dt-bindings: mfd: add rk806 binding
mfd: rk8xx: add rk806 support
pinctrl: rk805: add rk806 pinctrl support
regulator: expose regulator_find_closest_bigger
regulator: rk808: add rk806 support

.../bindings/mfd/rockchip,rk806.yaml | 406 +++++++++++++++++
drivers/clk/Kconfig | 2 +-
drivers/clk/clk-rk808.c | 34 +-
drivers/input/misc/Kconfig | 2 +-
drivers/mfd/Kconfig | 21 +-
drivers/mfd/Makefile | 4 +-
drivers/mfd/{rk808.c => rk8xx-core.c} | 350 +++++----------
drivers/mfd/rk8xx-i2c.c | 209 +++++++++
drivers/mfd/rk8xx-spi.c | 122 +++++
drivers/pinctrl/Kconfig | 2 +-
drivers/pinctrl/pinctrl-rk805.c | 189 +++++++-
drivers/power/supply/Kconfig | 2 +-
drivers/regulator/Kconfig | 2 +-
drivers/regulator/helpers.c | 22 +-
drivers/regulator/rk808-regulator.c | 383 ++++++++++++++++
drivers/rtc/Kconfig | 2 +-
include/linux/mfd/rk808.h | 417 +++++++++++++++++-
include/linux/regulator/driver.h | 2 +
sound/soc/codecs/Kconfig | 2 +-
19 files changed, 1889 insertions(+), 284 deletions(-)
create mode 100644 Documentation/devicetree/bindings/mfd/rockchip,rk806.yaml
rename drivers/mfd/{rk808.c => rk8xx-core.c} (71%)
create mode 100644 drivers/mfd/rk8xx-i2c.c
create mode 100644 drivers/mfd/rk8xx-spi.c

--
2.39.0

\
 
 \ /
  Last update: 2023-03-26 23:33    [W:0.102 / U:2.084 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site