lkml.org 
[lkml]   [2023]   [Jan]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [PATCH v7 7/9] dt/bindings: drm/bridge: it6505: Add mode-switch support
From
On 05/01/2023 14:24, Pin-yen Lin wrote:
> ITE IT6505 can be used in systems to switch the DP traffic between
> two downstreams, which can be USB Type-C DisplayPort alternate mode
> lane or regular DisplayPort output ports.

Use subject prefixes matching the subsystem (which you can get for
example with `git log --oneline -- DIRECTORY_OR_FILE` on the directory
your patch is touching).

>
> Update the binding to accommodate this usage by introducing a
> data-lanes and a mode-switch property on endpoints.
>
> Signed-off-by: Pin-yen Lin <treapking@chromium.org>
>
> ---
>
> Changes in v7:
> - Fixed issues reported by dt_binding_check.
> - Updated the schema and the example dts for data-lanes.
> - Changed to generic naming for the example dts node.
>
> Changes in v6:
> - Remove switches node and use endpoints and data-lanes property to
> describe the connections.
>
> .../bindings/display/bridge/ite,it6505.yaml | 95 ++++++++++++++++---
> 1 file changed, 84 insertions(+), 11 deletions(-)
>
> diff --git a/Documentation/devicetree/bindings/display/bridge/ite,it6505.yaml b/Documentation/devicetree/bindings/display/bridge/ite,it6505.yaml
> index b16a9d9127dd..1ee7cd0d2035 100644
> --- a/Documentation/devicetree/bindings/display/bridge/ite,it6505.yaml
> +++ b/Documentation/devicetree/bindings/display/bridge/ite,it6505.yaml
> @@ -77,20 +77,45 @@ properties:
> unevaluatedProperties: false
> description: Video port for DP output
>
> - properties:
> - endpoint:
> + patternProperties:
> + "^endpoint@[01]$":
> $ref: /schemas/graph.yaml#/$defs/endpoint-base
> unevaluatedProperties: false
>
> properties:
> + reg:
> + maxItems: 1
> +
> + remote-endpoint: true
> +
> data-lanes:
> - minItems: 1
> - uniqueItems: true
> - items:
> - - enum: [ 0, 1 ]
> - - const: 1
> - - const: 2
> - - const: 3
> + oneOf:
> + - minItems: 1

Drop minItems.

> + maxItems: 1

Actually drop this as well and just use items with one item (enum).

> + items:
> + enum: [0, 1, 2, 3]
> +
> + - items:
> + - const: 0
> + - const: 1
> +
> + - items:
> + - const: 2
> + - const: 3
> +
> + - items:
> + - const: 0
> + - const: 1
> + - const: 2
> + - const: 3
> +
> + mode-switch:
> + type: boolean
> + description: Register this node as a Type-C mode switch or not.
> +
> + required:
> + - reg
> + - remote-endpoint
>
> required:
> - port@0
> @@ -102,7 +127,6 @@ required:
> - pwr18-supply
> - interrupts
> - reset-gpios
> - - extcon
> - ports
>
> additionalProperties: false
> @@ -139,8 +163,11 @@ examples:
> };
>
> port@1 {
> + #address-cells = <1>;
> + #size-cells = <0>;
> reg = <1>;
> - it6505_out: endpoint {
> + it6505_out: endpoint@0 {
> + reg = <0>;
> remote-endpoint = <&dp_in>;
> data-lanes = <0 1>;
> };
> @@ -148,3 +175,49 @@ examples:
> };
> };
> };
> + - |
> + #include <dt-bindings/interrupt-controller/irq.h>
> +
> + i2c3 {

Just i2c

Best regards,
Krzysztof

\
 
 \ /
  Last update: 2023-03-26 23:29    [W:0.112 / U:0.676 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site