lkml.org 
[lkml]   [2023]   [Jan]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subject[PATCH v5 0/5] Add the Renesas USBF controller support
Date
Hi,

This series add support for the Renesas USBF controller (USB Device
Controller) available in the Renesas RZ/N1 SoC.

Based on previous iteration:
https://lore.kernel.org/lkml/20221213133302.218955-1-herve.codina@bootlin.com/
Custom debug macros present in the controller driver source code
have been replaced by dev_dbg() calls.

Best regards,
Herve Codina

Changes v4 -> v5:
- patch 1
Add 'Reviewed-by: Rob Herring <robh@kernel.org>'
Add 'Reviewed-by: Geert Uytterhoeven <geert+renesas@glider.be>'

- patch 3
Remove custom TRACE() and TRACEEP() debug macros and
use directly dev_dbg() instead.

- patch 2, 4 and 5
No changes

Changes v3 -> v4:
- v3 patches 1, 2, 3 and 4 removed

- Patch 1 (v3 patch 5)
Remove 'depends-on' property

- Patch 2 (v3 patch 6)
Add 'Reviewed-by: Geert Uytterhoeven <geert+renesas@glider.be>'

- Patch 3 (v3 patch 7)
Fix warning raised by the kernel test robot

- Patch 4 (v3 patch 8)
Remove 'depends-on' property
add 'Reviewed-by: Geert Uytterhoeven <geert+renesas@glider.be>'

- Patch 5 (v3 patch 9)
No changes

Changes v2 -> v3:
- v2 Patches 1, 2 and 3 removed.

- Patches 1, 2, 3 and 4 (new patches)

- Patch 5 (v2 patch 4):
Add 'depends-on' property
Removed redundant 'binding' word

- Patch 6 (new patch)

- Patch 7 (v2 patch 5)
Removed h2mode checking. This check is no more needed and the API no more
available.

- Patch 8 (v2 patch 6)
Add 'depends-on' property

- Patch 9 (v2 patch 7)
Fix file name

Changes v1 -> v2:
- Patch 1:
Rename r9a06g032_sysctrl_get_usb_h2mode to r9a06g032_sysctrl_get_usb_role
and return USB_ROLE_{HOST,DEVICE} or an error code.
Reword commit log

- Patches 2 and 3:
No changes. Some previous feedbacks still need to be taken into account
https://lore.kernel.org/all/20221107182642.05a09f2f@bootlin.com/
https://lore.kernel.org/all/20221107173614.474707d7@bootlin.com/

- Patch 4:
Rename file from renesas,usbf.yaml to renesas,rzn1-usbf.yaml.
Remove 'oneOf'.
Add blank line and line break.
Add 'power-domains'.
Reword commit log

- Patch 5:
Remove clocks handling (handled by runtime PM through the clock domain
pointed by power-domains).
Fix compilation warning raised by the 'kernel test robot'.

- Patch 6:
Add 'power-domains'

- Patch 7:
Add 'Reviewed-by: Geert Uytterhoeven <geert+renesas@glider.be>'


Herve Codina (5):
dt-bindings: usb: add the Renesas RZ/N1 USBF controller
soc: renesas: r9a06g032-sysctrl: Handle h2mode setting based on USBF
presence
usb: gadget: udc: add Renesas RZ/N1 USBF controller support
ARM: dts: r9a06g032: Add the USBF controller node
MAINTAINERS: add the Renesas RZ/N1 USBF controller entry

.../bindings/usb/renesas,rzn1-usbf.yaml | 68 +
MAINTAINERS | 8 +
arch/arm/boot/dts/r9a06g032.dtsi | 12 +
drivers/clk/renesas/r9a06g032-clocks.c | 28 +
drivers/usb/gadget/udc/Kconfig | 11 +
drivers/usb/gadget/udc/Makefile | 1 +
drivers/usb/gadget/udc/renesas_usbf.c | 3406 +++++++++++++++++
7 files changed, 3534 insertions(+)
create mode 100644 Documentation/devicetree/bindings/usb/renesas,rzn1-usbf.yaml
create mode 100644 drivers/usb/gadget/udc/renesas_usbf.c

--
2.38.1

\
 
 \ /
  Last update: 2023-03-26 23:28    [W:0.078 / U:0.108 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site