lkml.org 
[lkml]   [2023]   [Jan]   [2]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [PATCH 2/8] migrate_pages: separate hugetlb folios migration
Date
Andrew Morton <akpm@linux-foundation.org> writes:

> On Tue, 27 Dec 2022 08:28:53 +0800 Huang Ying <ying.huang@intel.com> wrote:
>
>> This is a preparation patch to batch the folio unmapping and moving
>> for the non-hugetlb folios. Based on that we can batch the TLB
>> shootdown during the folio migration and make it possible to use some
>> hardware accelerator for the folio copying.
>>
>> In this patch the hugetlb folios and non-hugetlb folios migration is
>> separated in migrate_pages() to make it easy to change the non-hugetlb
>> folios migration implementation.
>>
>> ...
>>
>> --- a/mm/migrate.c
>> +++ b/mm/migrate.c
>> @@ -1404,6 +1404,87 @@ struct migrate_pages_stats {
>> int nr_thp_split;
>> };
>>
>> +static int migrate_hugetlbs(struct list_head *from, new_page_t get_new_page,
>> + free_page_t put_new_page, unsigned long private,
>> + enum migrate_mode mode, int reason,
>> + struct migrate_pages_stats *stats,
>> + struct list_head *ret_folios)
>> +{
>> + int retry = 1;
>> + int nr_failed = 0;
>> + int nr_retry_pages = 0;
>> + int pass = 0;
>> + struct folio *folio, *folio2;
>> + int rc = 0, nr_pages;
>> +
>> + for (pass = 0; pass < 10 && retry; pass++) {
>
> Why 10?

This is inherited from the original max pass number from
migrate_pages(). Which is introduced in commit 49d2e9cc4544 ("[PATCH]
Swap Migration V5: migrate_pages() function"). From the code and commit
message, I don't find out why. I guess that we need some magic number
anyway.

Now, because the magic number is used in 2 places (migrate_pages() and
migrate_hugetlbs()), it's better to define it as a constant macro?

>> + retry = 0;
>> + nr_retry_pages = 0;
>> +
>> + list_for_each_entry_safe(folio, folio2, from, lru) {
>> + if (!folio_test_hugetlb(folio))
>> + continue;
>> +
>> + nr_pages = folio_nr_pages(folio);
>> +
>> + cond_resched();
>> +
>> + rc = unmap_and_move_huge_page(get_new_page,
>> + put_new_page, private,
>> + &folio->page, pass > 2, mode,
>> + reason, ret_folios);
>> + /*
>> + * The rules are:
>> + * Success: hugetlb folio will be put back
>> + * -EAGAIN: stay on the from list
>> + * -ENOMEM: stay on the from list
>> + * -ENOSYS: stay on the from list
>> + * Other errno: put on ret_folios list
>> + */
>> + switch(rc) {
>> + case -ENOSYS:
>> + /* Hugetlb migration is unsupported */
>> + nr_failed++;
>> + stats->nr_failed_pages += nr_pages;
>> + list_move_tail(&folio->lru, ret_folios);
>> + break;
>> + case -ENOMEM:
>> + /*
>> + * When memory is low, don't bother to try to migrate
>> + * other folios, just exit.
>> + */
>> + nr_failed++;
>> + stats->nr_failed_pages += nr_pages;
>> + goto out;
>> + case -EAGAIN:
>> + retry++;
>> + nr_retry_pages += nr_pages;
>> + break;
>> + case MIGRATEPAGE_SUCCESS:
>> + stats->nr_succeeded += nr_pages;
>> + break;
>> + default:
>> + /*
>> + * Permanent failure (-EBUSY, etc.):
>> + * unlike -EAGAIN case, the failed folio is
>> + * removed from migration folio list and not
>> + * retried in the next outer loop.
>> + */
>> + nr_failed++;
>> + stats->nr_failed_pages += nr_pages;
>> + break;
>> + }
>> + }
>> + }
>> +out:
>> + nr_failed += retry;
>> + stats->nr_failed_pages += nr_retry_pages;
>> + if (rc != -ENOMEM)
>> + rc = nr_failed;
>> +
>> + return rc;
>> +}
>
> The interpretation of the return value of this function is somewhat
> unobvious.
>
> I suggest that this function be fully commented.
>
> Why does a retry contribute to nr_failed. What is the interpretation
> of nr_failed. etcetera.

Sure. Will do that in the next version.

Best Regards,
Huang, Ying

\
 
 \ /
  Last update: 2023-03-26 23:25    [W:0.078 / U:2.080 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site