lkml.org 
[lkml]   [2022]   [Sep]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRE: [PATCH] RDMA/siw: Solve the error of compiling the 32BIT mips kernel when enable CONFIG_RDMA_SIW
Date


> -----Original Message-----
> From: jianghaoran <jianghaoran@kylinos.cn>
> Sent: Thursday, 1 September 2022 07:52
> To: Bernard Metzler <BMT@zurich.ibm.com>
> Cc: jgg@ziepe.ca; leon@kernel.org; linux-rdma@vger.kernel.org; linux-
> kernel@vger.kernel.org
> Subject: [EXTERNAL] [PATCH] RDMA/siw: Solve the error of compiling the
> 32BIT mips kernel when enable CONFIG_RDMA_SIW
>
> cross-compilation environment:
> ubuntu 20.04
> mips-linux-gnu-gcc (Ubuntu 10.3.0-1ubuntu1~20.04) 10.3.0
>
> generate a configuration file by make randconfig:
> CONFIG_32BIT=y
> CONFIG_RDMA_SIW=y
>
> the error message as follows:
> In file included from ../arch/mips/include/asm/page.h:270,
> from ../arch/mips/include/asm/io.h:29,
> from ../arch/mips/include/asm/mmiowb.h:5,
> from ../include/linux/spinlock.h:64,
> from ../include/linux/wait.h:9,
> from ../include/linux/net.h:19,
> from ../drivers/infiniband/sw/siw/siw_qp_tx.c:8:
> ../drivers/infiniband/sw/siw/siw_qp_tx.c: In function ‘siw_tx_hdt’:
> ../arch/mips/include/asm/page.h:255:53: error: cast to pointer from integer
> of different size [-Werror=int-to-pointer-cast]
> 255 | #define virt_to_pfn(kaddr) PFN_DOWN(virt_to_phys((void
> *)(kaddr)))
> | ^
> ../include/asm-generic/memory_model.h:18:41: note: in definition of macro
> ‘__pfn_to_page’
> 18 | #define __pfn_to_page(pfn) (mem_map + ((pfn) - ARCH_PFN_OFFSET))
> | ^~~
> ../arch/mips/include/asm/page.h:255:31: note: in expansion of macro
> ‘PFN_DOWN’
> 255 | #define virt_to_pfn(kaddr) PFN_DOWN(virt_to_phys((void
> *)(kaddr)))
> | ^~~~~~~~
> ../arch/mips/include/asm/page.h:256:41: note: in expansion of macro
> ‘virt_to_pfn’
> 256 | #define virt_to_page(kaddr) pfn_to_page(virt_to_pfn(kaddr))
> | ^~~~~~~~~~~
> ../drivers/infiniband/sw/siw/siw_qp_tx.c:538:23: note: in expansion of
> macro ‘virt_to_page’
> 538 | page_array[seg] = virt_to_page(va & PAGE_MASK);
> | ^~~~~~~~~~~~
> cc1: all warnings being treated as errors
> make[5]: *** [../scripts/Makefile.build:249:
> drivers/infiniband/sw/siw/siw_qp_tx.o] Error 1
> make[4]: *** [../scripts/Makefile.build:465: drivers/infiniband/sw/siw]
> Error 2
> make[3]: *** [../scripts/Makefile.build:465: drivers/infiniband/sw] Error 2
> make[3]: *** Waiting for unfinished jobs....
>
> Reported-by: k2ci <kernel-bot@kylinos.cn>
> Signed-off-by: jianghaoran <jianghaoran@kylinos.cn>
> ---
> drivers/infiniband/sw/siw/siw_qp_tx.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/infiniband/sw/siw/siw_qp_tx.c
> b/drivers/infiniband/sw/siw/siw_qp_tx.c
> index 1f4e60257700..55ed0c27f449 100644
> --- a/drivers/infiniband/sw/siw/siw_qp_tx.c
> +++ b/drivers/infiniband/sw/siw/siw_qp_tx.c
> @@ -533,7 +533,7 @@ static int siw_tx_hdt(struct siw_iwarp_tx *c_tx, struct
> socket *s)
> kunmap_local(kaddr);
> }
> } else {
> - u64 va = sge->laddr + sge_off;
> + unsigned long va = sge->laddr + sge_off;
>

We discussed same thing a few days ago - see PATCH from Linus:
'[PATCH] RDMA/siw: Pass a pointer to virt_to_page()'

While he suggested casting, I think it would be better to change
'u64' to 'uintptr_t'. I'd prefer 'uintptr_t' over 'unsigned long'
for readability -- since we hold a pointer.
It would also simplify a cast of va a few lines down in
virt_to_page().

Could one of you two re-send?

Thanks Jianghaoran!

Bernard.

> page_array[seg] = virt_to_page(va & PAGE_MASK);
> if (do_crc)
> --
> 2.25.1

\
 
 \ /
  Last update: 2022-09-01 09:08    [W:0.043 / U:0.048 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site