lkml.org 
[lkml]   [2022]   [Nov]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [PATCH 4/7] dt-bindings: usb: add the Renesas USBF controller binding
From
On 07/11/2022 14:58, Herve Codina wrote:
> The Renesas USBF controller is an USB2.0 device controller
> (UDC) available in Renesas r9a06g032 SoC (RZ/N1 family).
>
> Signed-off-by: Herve Codina <herve.codina@bootlin.com>
> ---
> .../devicetree/bindings/usb/renesas,usbf.yaml | 64 +++++++++++++++++++
> 1 file changed, 64 insertions(+)
> create mode 100644 Documentation/devicetree/bindings/usb/renesas,usbf.yaml
>
> diff --git a/Documentation/devicetree/bindings/usb/renesas,usbf.yaml b/Documentation/devicetree/bindings/usb/renesas,usbf.yaml
> new file mode 100644
> index 000000000000..f2b146d9d37b
> --- /dev/null
> +++ b/Documentation/devicetree/bindings/usb/renesas,usbf.yaml
> @@ -0,0 +1,64 @@
> +# SPDX-License-Identifier: (GPL-2.0-only OR BSD-2-Clause)
> +%YAML 1.2
> +---
> +$id: http://devicetree.org/schemas/usb/renesas,usbf.yaml#

Filename based on compatible, so renesas,rzn1-usbf.yaml.

> +$schema: http://devicetree.org/meta-schemas/core.yaml#
> +
> +title: Renesas USBF (USB Function) controller binding
> +
> +description: |
> + The Renesas USBF controller is an USB2.0 device
> + controller (UDC).
> +
> +maintainers:
> + - Herve Codina <herve.codina@bootlin.com>
> +
> +properties:
> + compatible:
> + oneOf:

You have only one possibility, so oneOf is not needed. Unless you
already predict it will grow with new incompatible lists?

> + - items:
> + - enum:
> + - renesas,r9a06g032-usbf
> + - const: renesas,rzn1-usbf
> +
> + reg:
> + maxItems: 1
> +
> + clocks:
> + items:
> + - description: Internal bus clock (AHB) for Function
> + - description: Internal bus clock (AHB) for Power Management

Blank line

> + clock-names:
> + items:
> + - const: hclkf
> + - const: hclkpm
> +
> + interrupts:
> + items:
> + - description: The USBF EPC interrupt
> + - description: The USBF AHB-EPC interrupt
> +
> +required:
> + - compatible
> + - reg
> + - clocks
> + - clock-names
> + - interrupts
> +
> +additionalProperties: false
> +
> +examples:
> + - |
> + #include <dt-bindings/interrupt-controller/arm-gic.h>
> + #include <dt-bindings/clock/r9a06g032-sysctrl.h>
> +
> + usb@4001e000 {
> + compatible = "renesas,r9a06g032-usbf", "renesas,rzn1-usbf";
> + reg = <0x4001e000 0x2000>;
> + interrupts =

No need for line break. It's not helping in readability.


> + <GIC_SPI 77 IRQ_TYPE_LEVEL_HIGH>,
> + <GIC_SPI 78 IRQ_TYPE_LEVEL_HIGH>;
> + clocks = <&sysctrl R9A06G032_HCLK_USBF>,
> + <&sysctrl R9A06G032_HCLK_USBPM>;
> + clock-names = "hclkf", "hclkpm";
> + };

Best regards,
Krzysztof

\
 
 \ /
  Last update: 2022-11-07 19:25    [W:0.151 / U:1.084 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site