lkml.org 
[lkml]   [2021]   [Sep]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] rapidio: Avoid bogus __alloc_size warning
On Thu,  9 Sep 2021 09:14:09 -0700 Kees Cook <keescook@chromium.org> wrote:

> GCC 9.3 (but not later) incorrectly evaluates the arguments to
> check_copy_size(), getting seemingly confused by the size being returned
> from array_size(). Instead, perform the calculation once, which both
> makes the code more readable and avoids the bug in GCC.
>
> In file included from arch/x86/include/asm/preempt.h:7,
> from include/linux/preempt.h:78,
> from include/linux/spinlock.h:55,
> from include/linux/mm_types.h:9,
> from include/linux/buildid.h:5,
> from include/linux/module.h:14,
> from drivers/rapidio/devices/rio_mport_cdev.c:13:
> In function 'check_copy_size',
> inlined from 'copy_from_user' at include/linux/uaccess.h:191:6,
> inlined from 'rio_mport_transfer_ioctl' at drivers/rapidio/devices/rio_mport_cdev.c:983:6:
> include/linux/thread_info.h:213:4: error: call to '__bad_copy_to' declared with attribute error: copy destination size is too small
> 213 | __bad_copy_to();
> | ^~~~~~~~~~~~~~~
>
> But the allocation size and the copy size are identical:
>
> transfer = vmalloc(array_size(sizeof(*transfer), transaction.count));
> if (!transfer)
> return -ENOMEM;
>
> if (unlikely(copy_from_user(transfer,
> (void __user *)(uintptr_t)transaction.block,
> array_size(sizeof(*transfer), transaction.count)))) {

That's an "error", not a warning. Or is this thanks to the new -Werror?

Either way, I'm inclined to cc:stable on this, because use of gcc-9 on
older kernels will be a common thing down the ages.

If it's really an "error" on non-Werror kernels then definitely cc:stable.

\
 
 \ /
  Last update: 2021-09-09 22:28    [W:0.233 / U:0.280 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site