lkml.org 
[lkml]   [2021]   [Aug]   [31]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH 2/6] mm/page_alloc.c: simplify the code by using macro K()
From
Date
On 30.08.21 16:10, Miaohe Lin wrote:
> Use helper macro K() to convert the pages to the corresponding size.
> Minor readability improvement.
>
> Signed-off-by: Miaohe Lin <linmiaohe@huawei.com>
> ---
> mm/page_alloc.c | 12 +++++-------
> 1 file changed, 5 insertions(+), 7 deletions(-)
>
> diff --git a/mm/page_alloc.c b/mm/page_alloc.c
> index dbb3338d9287..d3983244f56f 100644
> --- a/mm/page_alloc.c
> +++ b/mm/page_alloc.c
> @@ -8134,8 +8134,7 @@ unsigned long free_reserved_area(void *start, void *end, int poison, const char
> }
>
> if (pages && s)
> - pr_info("Freeing %s memory: %ldK\n",
> - s, pages << (PAGE_SHIFT - 10));
> + pr_info("Freeing %s memory: %ldK\n", s, K(pages));
>
> return pages;
> }
> @@ -8180,14 +8179,13 @@ void __init mem_init_print_info(void)
> ", %luK highmem"
> #endif
> ")\n",
> - nr_free_pages() << (PAGE_SHIFT - 10),
> - physpages << (PAGE_SHIFT - 10),
> + K(nr_free_pages()), K(physpages),
> codesize >> 10, datasize >> 10, rosize >> 10,
> (init_data_size + init_code_size) >> 10, bss_size >> 10,
> - (physpages - totalram_pages() - totalcma_pages) << (PAGE_SHIFT - 10),
> - totalcma_pages << (PAGE_SHIFT - 10)
> + K(physpages - totalram_pages() - totalcma_pages),
> + K(totalcma_pages)
> #ifdef CONFIG_HIGHMEM
> - , totalhigh_pages() << (PAGE_SHIFT - 10)
> + , K(totalhigh_pages())
> #endif
> );
> }
>

Reviewed-by: David Hildenbrand <david@redhat.com>

--
Thanks,

David / dhildenb

\
 
 \ /
  Last update: 2021-08-31 16:09    [W:0.597 / U:0.264 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site