lkml.org 
[lkml]   [2021]   [Jul]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
From
Subject[PATCH] mm/mempolicy: Use readable NUMA_NO_NODE macro instead of magic numer
Date
The caller of mpol_misplaced() already use NUMA_NO_NODE to check
whether current page node is misplaced, thus using NUMA_NO_NODE
in mpol_misplaced() instead of magic number is more readable.

Signed-off-by: Baolin Wang <baolin.wang@linux.alibaba.com>
---
mm/mempolicy.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/mm/mempolicy.c b/mm/mempolicy.c
index cedc816..038510d 100644
--- a/mm/mempolicy.c
+++ b/mm/mempolicy.c
@@ -2470,8 +2470,8 @@ static void sp_free(struct sp_node *n)
* node id. Policy determination "mimics" alloc_page_vma().
* Called from fault path where we know the vma and faulting address.
*
- * Return: -1 if the page is in a node that is valid for this policy, or a
- * suitable node ID to allocate a replacement page from.
+ * Return: NUMA_NO_NODE if the page is in a node that is valid for this
+ * policy, or a suitable node ID to allocate a replacement page from.
*/
int mpol_misplaced(struct page *page, struct vm_area_struct *vma, unsigned long addr)
{
@@ -2482,7 +2482,7 @@ int mpol_misplaced(struct page *page, struct vm_area_struct *vma, unsigned long
int thiscpu = raw_smp_processor_id();
int thisnid = cpu_to_node(thiscpu);
int polnid = NUMA_NO_NODE;
- int ret = -1;
+ int ret = NUMA_NO_NODE;

pol = get_vma_policy(vma, addr);
if (!(pol->flags & MPOL_F_MOF))
--
1.8.3.1
\
 
 \ /
  Last update: 2021-07-29 13:36    [W:0.020 / U:0.636 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site