lkml.org 
[lkml]   [2021]   [Jun]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [PATCH v1 1/1] spi: Remove unneeded parentheses in spi_map_buf()
On Mon, Jun 21, 2021 at 1:40 PM Mark Brown <broonie@kernel.org> wrote:
>
> On Sat, Jun 19, 2021 at 02:15:26PM +0300, Andy Shevchenko wrote:
> > The boolean expression to get kmap_buf is hard to read due to
> > too many unneeded parentheses. Remove them for good.
>
> > - const bool kmap_buf = ((unsigned long)buf >= PKMAP_BASE &&
> > - (unsigned long)buf < (PKMAP_BASE +
> > - (LAST_PKMAP * PAGE_SIZE)));
> > + const bool kmap_buf = (unsigned long)buf >= PKMAP_BASE &&
> > + (unsigned long)buf < (PKMAP_BASE + LAST_PKMAP * PAGE_SIZE);
>
> No, I think this makes things worse - to the extent there's an issue
> here it's not excessive brackets.

How? I can't see any issues here and dropping excessive brackets helps
to read it better. For example, the exterior brackets do nothing
except making it harder to read, i.e. the expression inside them is
already type of boolean and I have no clue what they are for.



--
With Best Regards,
Andy Shevchenko

\
 
 \ /
  Last update: 2021-06-21 12:44    [W:0.294 / U:0.084 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site