lkml.org 
[lkml]   [2021]   [Jun]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
Date
From
Subject[irqchip: irq/irqchip-next] irqdomain: Use struct_size() helper when allocating irqdomain
The following commit has been merged into the irq/irqchip-next branch of irqchip:

Commit-ID: 426fa316148bccabf48f9c91a13c387ee911eadc
Gitweb: https://git.kernel.org/pub/scm/linux/kernel/git/maz/arm-platforms/426fa316148bccabf48f9c91a13c387ee911eadc
Author: Marc Zyngier <maz@kernel.org>
AuthorDate: Mon, 05 Apr 2021 11:30:51 +01:00
Committer: Marc Zyngier <maz@kernel.org>
CommitterDate: Thu, 10 Jun 2021 13:09:17 +01:00

irqdomain: Use struct_size() helper when allocating irqdomain

Instead of open-coding the size computation of struct irqdomain,
use the struct_size() helper instead.

This is going to be handy as we change the type of the revmap
array.

Signed-off-by: Marc Zyngier <maz@kernel.org>
---
kernel/irq/irqdomain.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/kernel/irq/irqdomain.c b/kernel/irq/irqdomain.c
index fa94c86..cdcb198 100644
--- a/kernel/irq/irqdomain.c
+++ b/kernel/irq/irqdomain.c
@@ -150,7 +150,7 @@ struct irq_domain *__irq_domain_add(struct fwnode_handle *fwnode, int size,
(!IS_ENABLED(CONFIG_IRQ_DOMAIN_NOMAP) && direct_max)))
return NULL;

- domain = kzalloc_node(sizeof(*domain) + (sizeof(unsigned int) * size),
+ domain = kzalloc_node(struct_size(domain, revmap, size),
GFP_KERNEL, of_node_to_nid(to_of_node(fwnode)));
if (!domain)
return NULL;
\
 
 \ /
  Last update: 2021-06-11 15:56    [W:0.031 / U:0.308 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site