lkml.org 
[lkml]   [2021]   [Dec]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subject[PATCH v4 0/4] tracing: Add and use event_command parsing func helpers
Date
With more event commands being implemented, it's been pointed out that
it would make sense to clean up the existing ones and make it easier
to implement new ones without copying a lot of boilerplate. The main
culprit here is the event_command.func() callback - the rest of the
event_command infrastructure has default implementations that work for
most implementations. The func() callback is a little different in
that every new command needs to customize parsing to some extent.

This patchset attempts to help clean that up and make it easier for
new users to deal with.

v4: Added two patches changing the names of event_command.func() and
event_trigger_ops.func() to make them reflect their functions.

Added back missing kfree(trigger_data) in event_trigger_callback().

Changed char *param to const char *param in
event_trigger_check_remove() and event_trigger_empty_param().

Changed event_trigger_separate_filter() to use separate param and
filter outparams, and changed the name of the param inparam to
param_and_filter to better reflect its contents and avoid the
clash with new param outparam. Changed all parse()
implementations to use this new scheme.

Fixed some typos and added more extensive comments with examples
explaining various things that were mentioned as causing confusion
and just in general tried to clarify things with respect to the
callbacks and parameters.

v3: broke up event_trigger_check() into smaller functions instead of
parameterizing it, and added function documentation.

v2: removed unused event_trigger_remove(). No change in functionality.

The following changes since commit a6ed2aee54644cfa2d04ca86308767f5c3a087e8:

tracing: Switch to kvfree_rcu() API (2021-12-06 17:53:50 -0500)

are available in the Git repository at:

git://git.kernel.org/pub/scm/linux/kernel/git/zanussi/linux-trace.git ftrace/cleanup-hist-func-v4

Tom Zanussi (4):
tracing: Change event_command func() to parse()
tracing: Change event_trigger_ops func() to trigger()
tracing: Add helper functions to simplify event_command.parse()
callback handling
tracing: Have existing event_command.parse() implementations use
helpers

kernel/trace/trace.h | 63 +++-
kernel/trace/trace_eprobe.c | 11 +-
kernel/trace/trace_events_hist.c | 109 +++---
kernel/trace/trace_events_trigger.c | 558 ++++++++++++++++++++--------
4 files changed, 515 insertions(+), 226 deletions(-)

--
2.17.1

\
 
 \ /
  Last update: 2021-12-10 22:16    [W:0.085 / U:0.140 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site