lkml.org 
[lkml]   [2021]   [Nov]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subject[PATCH v2 0/2] Introduce x86_get_cpufreq_khz()
Date
v2:
- Rename x86_get_freq() to x86_get_cpufreq_khz() to make function
specific. (Suggested by Thomas Gleixner)
- Use cpu_feature_enabled(X86_FEATURE_TSC) instead of
cpu_has(&cpu_data(cpu), X86_FEATURE_TSC) to test feature.
(Suggested by Thomas Gleixner)
- Spell fixes. (Suggested by Thomas Gleixner)

v1:
- Introduce x86_get_freq(), hide detailed implemention from proc
routine.
- KVM uses x86_get_freq() to get CPU frequecy.

zhenwei pi (2):
x86/cpu: Introduce x86_get_cpufreq_khz()
KVM: x86: use x86_get_freq to get freq for kvmclock

arch/x86/include/asm/processor.h | 2 ++
arch/x86/kernel/cpu/common.c | 19 +++++++++++++++++++
arch/x86/kernel/cpu/proc.c | 13 +++----------
arch/x86/kvm/x86.c | 4 +---
4 files changed, 25 insertions(+), 13 deletions(-)

--
2.25.1

\
 
 \ /
  Last update: 2021-12-01 03:49    [W:0.086 / U:0.216 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site