lkml.org 
[lkml]   [2020]   [Sep]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
From
Subject[PATCH] rtc: rx8010: rename rx8010_init_client() to rx8010_init()
Date
From: Bartosz Golaszewski <bgolaszewski@baylibre.com>

Since the switch to using regmap this function no longer takes the
I2C client struct as argument nor do we even interact with the client
anywhere other than when creating the regmap.

Rename it to a less misleading name: "rx8010_init()".

Signed-off-by: Bartosz Golaszewski <bgolaszewski@baylibre.com>
---
drivers/rtc/rtc-rx8010.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/rtc/rtc-rx8010.c b/drivers/rtc/rtc-rx8010.c
index 01e9017d4025..dca41a2a39b2 100644
--- a/drivers/rtc/rtc-rx8010.c
+++ b/drivers/rtc/rtc-rx8010.c
@@ -169,7 +169,7 @@ static int rx8010_set_time(struct device *dev, struct rtc_time *dt)
return 0;
}

-static int rx8010_init_client(struct device *dev)
+static int rx8010_init(struct device *dev)
{
struct rx8010_data *rx8010 = dev_get_drvdata(dev);
u8 ctrl[2];
@@ -391,7 +391,7 @@ static int rx8010_probe(struct i2c_client *client)
if (IS_ERR(rx8010->regs))
return PTR_ERR(rx8010->regs);

- err = rx8010_init_client(dev);
+ err = rx8010_init(dev);
if (err)
return err;

--
2.26.1
\
 
 \ /
  Last update: 2020-09-17 13:49    [W:0.066 / U:0.516 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site