lkml.org 
[lkml]   [2020]   [May]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
From
Subject[PATCH 02/10] pstore: Rename "pstore_lock" to "psinfo_lock"
Date
The name "pstore_lock" sounds very global, but it is only supposed to be
used for managing changes to "psinfo", so rename it accordingly.

Signed-off-by: Kees Cook <keescook@chromium.org>
---
fs/pstore/platform.c | 10 +++++-----
1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/fs/pstore/platform.c b/fs/pstore/platform.c
index 44f8b9742263..347b6c07f4cf 100644
--- a/fs/pstore/platform.c
+++ b/fs/pstore/platform.c
@@ -69,10 +69,10 @@ static void pstore_dowork(struct work_struct *);
static DECLARE_WORK(pstore_work, pstore_dowork);

/*
- * pstore_lock just protects "psinfo" during
+ * psinfo_lock just protects "psinfo" during
* calls to pstore_register()
*/
-static DEFINE_SPINLOCK(pstore_lock);
+static DEFINE_SPINLOCK(psinfo_lock);
struct pstore_info *psinfo;

static char *backend;
@@ -574,11 +574,11 @@ int pstore_register(struct pstore_info *psi)
return -EINVAL;
}

- spin_lock(&pstore_lock);
+ spin_lock(&psinfo_lock);
if (psinfo) {
pr_warn("backend '%s' already loaded: ignoring '%s'\n",
psinfo->name, psi->name);
- spin_unlock(&pstore_lock);
+ spin_unlock(&psinfo_lock);
return -EBUSY;
}

@@ -587,7 +587,7 @@ int pstore_register(struct pstore_info *psi)
psinfo = psi;
mutex_init(&psinfo->read_mutex);
sema_init(&psinfo->buf_lock, 1);
- spin_unlock(&pstore_lock);
+ spin_unlock(&psinfo_lock);


if (psi->flags & PSTORE_FLAGS_DMESG)
--
2.20.1
\
 
 \ /
  Last update: 2020-05-06 17:22    [W:1.356 / U:0.284 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site