lkml.org 
[lkml]   [2020]   [Feb]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH V2 0/9] mmc: mmci: sdmmc: add sdr104 support
From
Date
hi Ulf

Just a "gentleman ping" on this series
https://patchwork.kernel.org/project/linux-mmc/list/?series=234011

Regards
Ludo

Le 1/28/20 à 10:06 AM, Ludovic Barre a écrit :
> To support the sdr104 mode, sdmmc variant needs:
> -Hardware delay block support for sdmmc variant
> with tuning procedure
> -Voltage switch callbacks
> -sdmmc revision 2.0
>
> V2:
> -regroup host->mmc_ops & mmc->ops assignment
> -add timeout define
> -rename prep_volt_switch to pre_sig_volt_switch
> -rename volt_switch to post_sig_volt_switch
> -add 'why' comment for "mmc: mmci: add volt_switch callbacks"
>
> Ludovic Barre (9):
> mmc: mmci: sdmmc: replace sg_dma_xxx macros
> mmc: mmci: sdmmc: rename sdmmc_priv struct to sdmmc_idma
> mmc: mmci: add a reference at mmc_host_ops in mmci struct
> mmc: mmci: add private pointer for variant
> dt-bindings: mmc: mmci: add delay block base register for sdmmc
> mmc: mmci: sdmmc: add execute tuning with delay block
> mmc: mmci: add volt_switch callbacks
> mmc: mmci: sdmmc: add voltage switch functions
> mmc: mmci: add sdmmc variant revision 2.0
>
> .../devicetree/bindings/mmc/mmci.txt | 2 +
> drivers/mmc/host/mmci.c | 42 +++-
> drivers/mmc/host/mmci.h | 8 +
> drivers/mmc/host/mmci_stm32_sdmmc.c | 204 +++++++++++++++++-
> 4 files changed, 248 insertions(+), 8 deletions(-)
>

\
 
 \ /
  Last update: 2020-02-11 15:48    [W:0.147 / U:0.520 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site