lkml.org 
[lkml]   [2020]   [Dec]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH 2/3] vfs: Add a super block operation to check for writeback errors
From
Date
On Tue, 2020-12-22 at 11:25 -0500, Vivek Goyal wrote:
> On Tue, Dec 22, 2020 at 04:19:00PM +0000, Matthew Wilcox wrote:
> > On Mon, Dec 21, 2020 at 02:50:54PM -0500, Vivek Goyal wrote:
> > > - ret2 = errseq_check_and_advance(&sb->s_wb_err, &f.file->f_sb_err);
> > > + if (sb->s_op->errseq_check_advance)
> > > + ret2 = sb->s_op->errseq_check_advance(sb, f.file);
> >
> > What a terrible name for an fs operation. You don't seem to be able
> > to distinguish between semantics and implementation. How about
> > check_error()?
>
> check_error() sounds better. I was not very happy with the name either.
> Thought of starting with something.
>

Maybe report_error() ?

The same error won't be reported on the next call on the same fd. I
think the important point to make here is that this error must be
reported to syncfs() or something like it once you call this.

(In hindsight, I sort of wish I had done s/serrseq_set/errseq_record/
and s/errseq_check_and_advance/errseq_report/ when I initially did this,
if only to make the API a little less dependent on the implementation.)
--
Jeff Layton <jlayton@kernel.org>

\
 
 \ /
  Last update: 2020-12-23 13:46    [W:0.063 / U:0.576 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site