lkml.org 
[lkml]   [2019]   [Jun]   [26]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [patch 24/29] x86/hpet: Use cached info instead of extra flags

* Thomas Gleixner <tglx@linutronix.de> wrote:

> Now that HPET clockevent support is integrated into the channel data, reuse
> the cached boot configuration instead of copying the same information into
> a flags field.
>
> This also allows to consolidate the reservation code into one place, which
> can now solely depend on the mode information.
>
> Signed-off-by: Thomas Gleixner <tglx@linutronix.de>
> ---
> arch/x86/kernel/hpet.c | 76 ++++++++++++++-----------------------------------
> 1 file changed, 23 insertions(+), 53 deletions(-)
>
> --- a/arch/x86/kernel/hpet.c
> +++ b/arch/x86/kernel/hpet.c
> @@ -25,8 +25,8 @@ struct hpet_channel {
> unsigned int num;
> unsigned int cpu;
> unsigned int irq;
> + unsigned int inuse;
> enum hpet_mode mode;
> - unsigned int flags;
> unsigned int boot_cfg;
> char name[10];

Let's fight entropy name by name and s/inuse/in_use ?

Because in_use is closer to harmony:

dagon:~/tip> git grep -w in_use | wc -l
518
dagon:~/tip> git grep -w inuse | wc -l
318

and also easier to read.

Reviewed-by: Ingo Molnar <mingo@kernel.org>

Thanks,

Ingo

\
 
 \ /
  Last update: 2019-06-26 23:21    [W:0.263 / U:0.072 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site