lkml.org 
[lkml]   [2019]   [Dec]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subject[PATCH 0/2] KVM: x86: X86_FEATURE bit() cleanup
Date
Small series to add build-time protections on reverse CPUID lookup (and
other usages of bit()), and to rename the misleading-generic bit() helper
to something that better conveys its purpose.

Sean Christopherson (2):
KVM: x86: Add build-time assertion on usage of bit()
KVM: x86: Refactor and rename bit() to feature_bit() macro

arch/x86/kvm/cpuid.c | 2 +-
arch/x86/kvm/cpuid.h | 4 ++--
arch/x86/kvm/emulate.c | 8 +++-----
arch/x86/kvm/svm.c | 4 ++--
arch/x86/kvm/vmx/vmx.c | 42 +++++++++++++++++++++---------------------
arch/x86/kvm/x86.h | 24 ++++++++++++++++++++++--
6 files changed, 51 insertions(+), 33 deletions(-)

--
2.24.0

\
 
 \ /
  Last update: 2019-12-11 18:58    [W:1.402 / U:0.004 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site