lkml.org 
[lkml]   [2019]   [Jan]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectNouveau module results in total lockups without any dmesg trace on a NP900X5N Kaby Lake machine
Date
Hi Ben, David and Daniel ,

First of all happy new year. Based on advice of Greg K-H herewith a mail
about a number of Nouveau issues with my laptop.

I installed various Kali linux versions up to Linux 4.20.0-rc7
(downloaded, compiled and installed) on a Samsung NP900X5N laptop and
have an issue with the driver after loading.

My configuration:

- i7 7500
- 16 gb / 256 gb ssd
- nvidia 940MX (for 3D graphics)

When I enable loading of the nouveau module for my Nvidia 3D card I get
three MMIO faults:

[ 35.984104] nouveau 0000:01:00.0: bus: MMIO read of 00000000 FAULT at 6013d4 [ IBUS ]
[ 35.997510] nouveau 0000:01:00.0: bus: MMIO read of 00000000 FAULT at 10ac08 [ IBUS ]
[ 37.551790] nouveau 0000:01:00.0: bus: MMIO read of 00000000 FAULT at 619444 [ IBUS ]

I see currenty varous discussions on bugzilla: (as summarized by Bruno
Pagani) https://bugs.freedesktop.org/show_bug.cgi?id=100423.

But I do not see any confirmed solutions on the MMIO faults.

The module is loaded but X server cannot run in framebuffer mode. I
assume that the module does not provide any video memory to X to run in
graphics mode.

First of all I would like to understand what the faults impose.
And I also would like to help you providing testing to fix the errors.

Many thanks for your kind support.


--

Met vriendelijke groet,

*dr. Jan Vlietland*, namens

spin-off

Nederlands Instituut voor de Software Industrie

_j.vlietland@nisi.nl_| 06 – 20 411 834 | 030 – 268 53 98
Princetonplein 5 | 3584 CC  Utrecht | www.nisi.nl



\
 
 \ /
  Last update: 2019-01-01 22:00    [W:0.065 / U:1.428 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site