lkml.org 
[lkml]   [2018]   [Aug]   [31]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subject[PATCH 0/5] kdb: Cleanup code to read user input and handle escape sequences
Date
I spend a little time earlier this month looking at kdb_read() and ended
up doing a little light refactoring a bit to make easier to read.

Most of the patches are simple tidy ups although patches 4 and 5
introduce new behaviours. Patch 4 is probably not controversial
but perhaps patch 5 is ;-).

Tested as shown here:
https://github.com/daniel-thompson/kgdbtest/commit/c65e28d99357c2df6dac2cebe195574e634d04dc

Daniel Thompson (5):
kdb: Tidy up code to handle escape sequences
kdb: Simplify code to fetch characters from console
kdb: Remove special case logic from kdb_read()
kdb: Improve handling of characters from different input sources
kdb: Tweak escape handling for vi users

kernel/debug/kdb/kdb_io.c | 218 +++++++++++++++++---------------------
1 file changed, 99 insertions(+), 119 deletions(-)

--
2.17.1

\
 
 \ /
  Last update: 2018-08-31 22:52    [W:0.041 / U:0.380 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site