Messages in this thread |  | | Date | Fri, 17 Aug 2018 18:22:13 -0700 | From | Matthew Wilcox <> | Subject | Re: [PATCH RFC] mm: don't miss the last page because of round-off error |
| |
On Fri, Aug 17, 2018 at 04:18:34PM -0700, Roman Gushchin wrote: > - scan = div64_u64(scan * fraction[file], > - denominator); > + if (scan > 1) > + scan = div64_u64(scan * fraction[file], > + denominator);
Wouldn't we be better off doing a div_round_up? ie:
scan = div64_u64(scan * fraction[file] + denominator - 1, denominator);
although i'd rather hide that in a new macro in math64.h than opencode it here.
|  |