Messages in this thread |  | | From | Konstantin Khlebnikov <> | Date | Tue, 21 Aug 2018 08:11:44 +0300 | Subject | Re: [PATCH RFC] mm: don't miss the last page because of round-off error |
| |
On Sat, Aug 18, 2018 at 4:22 AM, Matthew Wilcox <willy@infradead.org> wrote: > On Fri, Aug 17, 2018 at 04:18:34PM -0700, Roman Gushchin wrote: >> - scan = div64_u64(scan * fraction[file], >> - denominator); >> + if (scan > 1) >> + scan = div64_u64(scan * fraction[file], >> + denominator); > > Wouldn't we be better off doing a div_round_up? ie: > > scan = div64_u64(scan * fraction[file] + denominator - 1, denominator); > > although i'd rather hide that in a new macro in math64.h than opencode it > here.
All numbers here should be up to nr_pages * 200 and fit into unsigned long. I see no reason for u64. If they overflow then u64 wouldn't help either.
There is macro DIV_ROUND_UP in kernel.h
|  |