lkml.org 
[lkml]   [2018]   [Jun]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH 02/19] sched/numa: Evaluate move once per node
From
Date
On Mon, 2018-06-04 at 15:30 +0530, Srikar Dronamraju wrote:

> @@ -1564,97 +1563,73 @@ static void task_numa_compare(struct
> task_numa_env *env,
> if (cur == env->p)
> goto unlock;
>
> + if (!cur) {
> + if (!move || imp <= env->best_imp)
> + goto unlock;
> + else
> + goto assign;
> + }

Just bike shedding, but it may be easier to read
if the "we found our destination" check were written
more explicitly:


if (!cur) {
if (move && imp > env->best_imp)
gote assign;
else
goto unlock;
}

Also, the "move" variable seems to indicate that
the NUMA code may move the task, but not a decision
that moving the task is better than a swap.

Would it make sense to call it "maymove"?

I like how this patch simplifies the code a little.

--
All Rights Reversed.[unhandled content-type:application/pgp-signature]
\
 
 \ /
  Last update: 2018-06-04 16:52    [W:0.262 / U:3.836 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site