lkml.org 
[lkml]   [2017]   [Oct]   [2]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 06/18] drm: use ARRAY_SIZE
On Sun, Oct 01, 2017 at 03:30:44PM -0400, Jérémy Lefaure wrote:
> Using the ARRAY_SIZE macro improves the readability of the code. Also,
> it is not always useful to use a variable to store this constant
> calculated at compile time nor to re-invent the ARRAY_SIZE macro.
>
> Found with Coccinelle with the following semantic patch:
> @r depends on (org || report)@
> type T;
> T[] E;
> position p;
> @@
> (
> (sizeof(E)@p /sizeof(*E))
> |
> (sizeof(E)@p /sizeof(E[...]))
> |
> (sizeof(E)@p /sizeof(T))
> )
>
> Signed-off-by: Jérémy Lefaure <jeremy.lefaure@lse.epita.fr>
> ---
> drivers/gpu/drm/amd/amdgpu/gfx_v8_0.c | 9 +++++----
> drivers/gpu/drm/amd/amdgpu/gfx_v9_0.c | 9 +++++----
> drivers/gpu/drm/gma500/psb_intel_sdvo.c | 9 ++++-----
> drivers/gpu/drm/i915/gvt/vgpu.c | 3 ++-
> drivers/gpu/drm/nouveau/nvkm/subdev/bios/init.c | 7 ++++---
> drivers/gpu/drm/via/via_verifier.c | 10 ++++------
> 6 files changed, 24 insertions(+), 23 deletions(-)

Reviewed-by: Thierry Reding <treding@nvidia.com>
[unhandled content-type:application/pgp-signature]
\
 
 \ /
  Last update: 2017-10-02 10:27    [W:0.286 / U:0.100 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site