lkml.org 
[lkml]   [2017]   [Oct]   [2]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [PATCH 06/18] drm: use ARRAY_SIZE
Date
On Sun, 01 Oct 2017, Jérémy Lefaure <jeremy.lefaure@lse.epita.fr> wrote:
> Using the ARRAY_SIZE macro improves the readability of the code. Also,
> it is not always useful to use a variable to store this constant
> calculated at compile time nor to re-invent the ARRAY_SIZE macro.
>
> Found with Coccinelle with the following semantic patch:
> @r depends on (org || report)@
> type T;
> T[] E;
> position p;
> @@
> (
> (sizeof(E)@p /sizeof(*E))
> |
> (sizeof(E)@p /sizeof(E[...]))
> |
> (sizeof(E)@p /sizeof(T))
> )
>
> Signed-off-by: Jérémy Lefaure <jeremy.lefaure@lse.epita.fr>

Please split this up.

Patch 1:
> drivers/gpu/drm/amd/amdgpu/gfx_v8_0.c | 9 +++++----
> drivers/gpu/drm/amd/amdgpu/gfx_v9_0.c | 9 +++++----

Patch 2:
> drivers/gpu/drm/gma500/psb_intel_sdvo.c | 9 ++++-----

Patch 3:
> drivers/gpu/drm/i915/gvt/vgpu.c | 3 ++-

Patch 4:
> drivers/gpu/drm/nouveau/nvkm/subdev/bios/init.c | 7 ++++---

Patch 5:
> drivers/gpu/drm/via/via_verifier.c | 10 ++++------

BR,
Jani.

--
Jani Nikula, Intel Open Source Technology Center

\
 
 \ /
  Last update: 2017-10-02 09:44    [W:0.251 / U:0.476 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site