lkml.org 
[lkml]   [2015]   [Sep]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
Date
From
SubjectRe: [PATCH] mm/mmap.c: Remove useless statement "vma = NULL" in find_vma()
On 9/11/15 02:19, Oleg Nesterov wrote:
> On 09/10, Chen Gang wrote:
>> - If "addr>= vm_start", we return this vma (else continue searching).
>
> This is optimization, we can stop the search because in this case
> vma == tmp is obviously the 1st vma with "addr < vm_end".
>

OK, thanks.

I guess if we have additional comments for "if (tmp->vm_start <= addr)",
the code will be more readable for readers (especially for newbies).

@@ -2064,7 +2064,7 @@ struct vm_area_struct *find_vma(struct mm_struct *mm, unsigned long addr)
if (tmp->vm_end > addr) {
vma = tmp;
if (tmp->vm_start <= addr)
- break;
+ break; /* It must be 1st "addr < vm_end" */
rb_node = rb_node->rb_left;
} else
rb_node = rb_node->rb_right;

> I simply can't understand your concerns. Perhaps you can make a
> patch, then it will be more clear what me-or-you have missed.
>

I guess, we need not (it is my missing). :-)


Thanks.
--
Chen Gang (陈刚)

Open, share, and attitude like air, water, and life which God blessed


\
 
 \ /
  Last update: 2015-09-11 00:41    [W:0.039 / U:0.808 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site