lkml.org 
[lkml]   [2015]   [Jun]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [PATCH 3/3] kdbus: optimize if statements in kdbus_conn_disconnect()
From
Hi

On Wed, Jun 17, 2015 at 7:14 PM, Sergei Zviagintsev <sergei@s15v.net> wrote:
> if (r->sync) branch and code after it both call kdbus_reply_unlink().
> Rewrite them as if-else to eliminate code duplication and make algorithm
> more obvious.
>
> Convert outer if statement to use continue in order to reduce
> indentation and make things easier to read.
>
> Signed-off-by: Sergei Zviagintsev <sergei@s15v.net>
> ---
> ipc/kdbus/connection.c | 15 +++++++--------
> 1 file changed, 7 insertions(+), 8 deletions(-)

Reviewed-by: David Herrmann <dh.herrmann@gmail.com>

Thanks
David

> diff --git a/ipc/kdbus/connection.c b/ipc/kdbus/connection.c
> index 707be050b408..9993753d11de 100644
> --- a/ipc/kdbus/connection.c
> +++ b/ipc/kdbus/connection.c
> @@ -559,17 +559,16 @@ int kdbus_conn_disconnect(struct kdbus_conn *conn, bool ensure_queue_empty)
> hash_for_each(bus->conn_hash, i, c, hentry) {
> mutex_lock(&c->lock);
> list_for_each_entry_safe(r, r_tmp, &c->reply_list, entry) {
> - if (r->reply_src == conn) {
> - if (r->sync) {
> - kdbus_sync_reply_wakeup(r, -EPIPE);
> - kdbus_reply_unlink(r);
> - continue;
> - }
> + if (r->reply_src != conn)
> + continue;
>
> + if (r->sync)
> + kdbus_sync_reply_wakeup(r, -EPIPE);
> + else
> /* send a 'connection dead' notification */
> kdbus_notify_reply_dead(bus, c->id, r->cookie);
> - kdbus_reply_unlink(r);
> - }
> +
> + kdbus_reply_unlink(r);
> }
> mutex_unlock(&c->lock);
> }
> --
> 1.8.3.1
>


\
 
 \ /
  Last update: 2015-06-17 19:41    [W:0.084 / U:0.684 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site