lkml.org 
[lkml]   [2015]   [Apr]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] usb: musb: Kconfig: Depend on some machines under blackfin
On Sun, Apr 05, 2015 at 06:33:44AM +0800, Chen Gang wrote:
> On 4/4/15 17:54, Greg Kroah-Hartman wrote:
> > On Sat, Apr 04, 2015 at 05:51:21AM +0800, Chen Gang wrote:
> >> Under blackfin, only bf527, bf548 and bf609 may use musb. The related
> >> error with allmodconfig:
> >>
> >> CC [M] drivers/usb/misc/trancevibrator.o
> >> In file included from drivers/usb/musb/musb_core.h:70:0,
> >> from drivers/usb/musb/musb_core.c:103:
> >> drivers/usb/musb/musb_core.c: In function 'musb_indexed_ep_select':
> >> drivers/usb/musb/musb_regs.h:458:32: error: 'USB_INDEX' undeclared (first use in this function)
> >> #define MUSB_INDEX USB_OFFSET(USB_INDEX) /* 8 bit */
> >> ^
> >>
> >> Signed-off-by: Chen Gang <gang.chen.5i5j@gmail.com>
> >
> > Why not fix the root cause and provide this symbol on blackfin? There's
> > no specific reason why it shouldn't be able to be built on this
> > platform.
> >
> > It's better to make platforms properly build everything, patches like
> > this just make things messier and harder to maintain.
> >
>
> I am not quite sure all machines of blackfin can support musb (according
> to current code, at present, we can only sure bf527, bf548 and bf609 can
> support it).

What do you mean by "can support"? What is missing? Why doesn't the
code build there?

> So, I suggest to add new macro HAVE_MUSB for BLACKFIN in patch v2. And
> welcome any other members' idea.

I recommend fixing blackfin, what makes this one specific platform so
broken compared to the 20+ other platforms that don't need this special
treatment?

thanks,

greg k-h


\
 
 \ /
  Last update: 2015-04-05 11:01    [W:0.054 / U:0.352 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site