lkml.org 
[lkml]   [2015]   [Nov]   [16]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 2/7] mm/hugetlb: is_file_hugepages can be boolean
On Mon 16-11-15 14:51:21, Yaowei Bai wrote:
> This patch makes is_file_hugepages return bool to improve
> readability due to this particular function only using either
> one or zero as its return value.
>
> This patch also removed the if condition to make is_file_hugepages
> return directly.
>
> No functional change.
>
> Signed-off-by: Yaowei Bai <baiyaowei@cmss.chinamobile.com>

I think this could be squashed into the previous patch.

Acked-by: Michal Hocko <mhocko@suse.com>

> ---
> include/linux/hugetlb.h | 10 ++++------
> 1 file changed, 4 insertions(+), 6 deletions(-)
>
> diff --git a/include/linux/hugetlb.h b/include/linux/hugetlb.h
> index 685c262..204c7f5 100644
> --- a/include/linux/hugetlb.h
> +++ b/include/linux/hugetlb.h
> @@ -265,20 +265,18 @@ struct file *hugetlb_file_setup(const char *name, size_t size, vm_flags_t acct,
> struct user_struct **user, int creat_flags,
> int page_size_log);
>
> -static inline int is_file_hugepages(struct file *file)
> +static inline bool is_file_hugepages(struct file *file)
> {
> if (file->f_op == &hugetlbfs_file_operations)
> - return 1;
> - if (is_file_shm_hugepages(file))
> - return 1;
> + return true;
>
> - return 0;
> + return is_file_shm_hugepages(file);
> }
>
>
> #else /* !CONFIG_HUGETLBFS */
>
> -#define is_file_hugepages(file) 0
> +#define is_file_hugepages(file) false
> static inline struct file *
> hugetlb_file_setup(const char *name, size_t size, vm_flags_t acctflag,
> struct user_struct **user, int creat_flags,
> --
> 1.9.1
>
>

--
Michal Hocko
SUSE Labs


\
 
 \ /
  Last update: 2015-11-16 14:01    [W:0.082 / U:1.528 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site