lkml.org 
[lkml]   [2014]   [Jul]   [18]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH 25/25] ipack: Replace DEFINE_PCI_DEVICE_TABLE macro use
From
Date
On Fri, 2014-07-18 at 17:27 +0200, Benoit Taine wrote:
> We should prefer `struct pci_device_id` over `DEFINE_PCI_DEVICE_TABLE` to meet
> kernel coding style guidelines. This issue was reported by checkpatch.
>
> Signed-off-by: Benoit Taine <benoit.taine@lip6.fr>
>
> ---
> Tested by compilation without errors.
>
> drivers/ipack/carriers/tpci200.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/ipack/carriers/tpci200.c b/drivers/ipack/carriers/tpci200.c
> index c276fde..de5e321 100644
> --- a/drivers/ipack/carriers/tpci200.c
> +++ b/drivers/ipack/carriers/tpci200.c
> @@ -618,7 +618,7 @@ static void tpci200_pci_remove(struct pci_dev *dev)
> __tpci200_pci_remove(tpci200);
> }
>
> -static DEFINE_PCI_DEVICE_TABLE(tpci200_idtable) = {
> +static const struct pci_device_id tpci200_idtable[] = {
> { TPCI200_VENDOR_ID, TPCI200_DEVICE_ID, TPCI200_SUBVENDOR_ID,
> TPCI200_SUBDEVICE_ID },
> { 0, },
>
>

Acked-by: Samuel Iglesias Gonsalvez <siglesias@igalia.com>

Greg, Would you mind picking this patch through your char-misc tree?

Thanks,

Sam
[unhandled content-type:application/pgp-signature]
\
 
 \ /
  Last update: 2014-07-18 19:21    [W:1.358 / U:0.060 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site