lkml.org 
[lkml]   [2013]   [Jul]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subject[PATCH v3 01/10] Driver core and sysfs changes for attribute groups
Date
Hi all,

Here is the third iteration of the patchset to add better attribute
group support to the driver core and sysfs.

Others have now tested it, and we got 3 more patches fixing a warning
that was showing up when binary attributes were in a group with no
"normal" attributes, and some more helper macros were added and cleaned
up.

I've booted this successfully against 3.11-rc1 with no problems (am
sending these from that machine.)

Ian, I didn't add a DEVICE_PATTR() macro yet, that can come later. I
considered it, but that would also mean a BUS_PATTR() and the like, which I
guess works, but I hate even a _hint_ of "Hungarian" notation, which this
implies.

Anyone else have a better name for this macro:
#define DEVICE_PATTR(_name) &dev_attr_##_name.attr
that they can think of? It will cut down on the typing done for
attribute lists.

changes from v3:
- tested by Guenter
- patches from Oliver added
- refreshed on 3.11-rc1 (minor fuzz)
- Ian glanced at them.

changes from v2:
- actually boots
- 7th patch added properly
- added BUS_ATTR, CLASS_ATTR, and DRIVER_ATTR RW and RO macros
to help with converting code to use attributes properly.

thanks,

greg k-h



\
 
 \ /
  Last update: 2013-07-15 01:41    [W:0.079 / U:0.340 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site