lkml.org 
[lkml]   [2013]   [Oct]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
Date
From
SubjectRe: [PATCH 1/4] perf tools: Split -g and --call-graph for record command
On 10/26/13 8:25 AM, Jiri Olsa wrote:
> diff --git a/tools/perf/Documentation/perf-record.txt b/tools/perf/Documentation/perf-record.txt
> index f10ab63..7be62770 100644
> --- a/tools/perf/Documentation/perf-record.txt
> +++ b/tools/perf/Documentation/perf-record.txt
> @@ -92,8 +92,12 @@ OPTIONS
> size is rounded up to have nearest pages power of two value.
>
> -g::
> + Enables call-graph (stack chain/backtrace) recording.
> +
> --call-graph::
> - Do call-graph (stack chain/backtrace) recording.
> + Setup and enable call-graph (stack chain/backtrace) recording,
> + implies -g.
> +

This needs some more words as to why it is used over -g. It is also
missing the options that can be given (fp or dwarf).

---8<---

> @@ -825,9 +851,12 @@ const struct option record_options[] = {
> perf_evlist__parse_mmap_pages),
> OPT_BOOLEAN(0, "group", &record.opts.group,
> "put the counters into a counter group"),
> - OPT_CALLBACK_DEFAULT('g', "call-graph", &record.opts,
> - "mode[,dump_size]", record_callchain_help,
> - &record_parse_callchain_opt, "fp"),
> + OPT_CALLBACK(0, "call-graph", &record.opts,
> + "mode[,dump_size]", record_callchain_help,
> + &record_parse_callchain_opt),
> + OPT_CALLBACK_NOOPT('g', NULL, &record.opts,
> + NULL, "enables call-graph recording" ,
> + &record_callchain_opt),

From a user/readability perspective I would prefer the order to be -g
then --call-graph especially since --call-graph is like an advanced -g
where you get more control over the method used.

Other than that:

Tested-Reviewed-by: David Ahern <dsahern@gmail.com>

David



\
 
 \ /
  Last update: 2013-10-27 16:41    [W:0.190 / U:0.228 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site