lkml.org 
[lkml]   [2008]   [May]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
Date
From
Subject[PATCH] sched: Improve readability in update_cpu_load() code
Author: Gautham R Shenoy <ego@in.ibm.com>
Date: Thu May 15 17:55:49 2008 +0530

sched: Improve readability in update_cpu_load() code

Currently the cpu_load[i] is calculated as:
this_rq->cpu_load[i] = (old_load*(scale-1) + new_load) >> i;

However, since scale = 2^i, this can be simplified as:
this_rq->cpu_load[i] = old_load + ((new_load - old_load) >> i);

Makes it easier to read.
Signed-off-by: Gautham R Shenoy <ego@in.ibm.com>

diff --git a/kernel/sched.c b/kernel/sched.c
index 2d7d8f1..e1a6985 100644
--- a/kernel/sched.c
+++ b/kernel/sched.c
@@ -2921,7 +2921,7 @@ static void update_cpu_load(struct rq *this_rq)
*/
if (new_load > old_load)
new_load += scale-1;
- this_rq->cpu_load[i] = (old_load*(scale-1) + new_load) >> i;
+ this_rq->cpu_load[i] = old_load + ((new_load - old_load) >> i);
}
}

--
Thanks and Regards
gautham

\
 
 \ /
  Last update: 2008-05-15 15:05    [W:0.036 / U:2.912 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site