lkml.org 
[lkml]   [2008]   [Apr]   [18]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
Date
From
Subject[PATCH] [POWERPC] i2c: fix build breakage introduced by OF helpers
Fix build breakage introduced in commit
"[POWERPC] i2c: OF helpers for the i2c API".
If i2c-core is compiled as module, the helper needs to be
compiled as module, as well. Rename i2c.c to of_i2c.c to
avoid name space conflict.

Signed-off-by: Jochen Friedrich <jochen@scram.de>
---
drivers/of/Kconfig | 2 +-
drivers/of/Makefile | 2 +-
drivers/of/{i2c.c => of_i2c.c} | 0
3 files changed, 2 insertions(+), 2 deletions(-)
rename drivers/of/{i2c.c => of_i2c.c} (100%)

diff --git a/drivers/of/Kconfig b/drivers/of/Kconfig
index 7c30531..0e39f00 100644
--- a/drivers/of/Kconfig
+++ b/drivers/of/Kconfig
@@ -9,7 +9,7 @@ config OF_GPIO
OpenFirmware GPIO accessors

config OF_I2C
- def_bool y
+ def_tristate I2C
depends on OF && I2C
help
OpenFirmware I2C accessors
diff --git a/drivers/of/Makefile b/drivers/of/Makefile
index a07b953..548772e 100644
--- a/drivers/of/Makefile
+++ b/drivers/of/Makefile
@@ -1,4 +1,4 @@
obj-y = base.o
obj-$(CONFIG_OF_DEVICE) += device.o platform.o
obj-$(CONFIG_OF_GPIO) += gpio.o
-obj-$(CONFIG_OF_I2C) += i2c.o
+obj-$(CONFIG_OF_I2C) += of_i2c.o
diff --git a/drivers/of/i2c.c b/drivers/of/of_i2c.c
similarity index 100%
rename from drivers/of/i2c.c
rename to drivers/of/of_i2c.c
--
1.5.5


\
 
 \ /
  Last update: 2008-04-18 16:25    [W:0.054 / U:0.132 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site