lkml.org 
[lkml]   [2006]   [Feb]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [ 01/10] [Suspend2] kernel/power/modules.h
Date
Hi.

On Wednesday 01 February 2006 23:01, Pekka Enberg wrote:
> On 2/1/06, Nigel Cunningham <nigel@suspend2.net> wrote:
> > --- /dev/null
> > +++ b/kernel/power/modules.h
> >
> > +struct module_header {
>
> [snip]
>
> > +extern int num_modules, num_writers;
>
> [snip]
>
> > +extern struct suspend_module_ops *active_writer;
>
> [snip]
>
> > +extern void prepare_console_modules(void);
> > +extern void cleanup_console_modules(void);
>
> [snip, snip]
>
> > +extern unsigned long header_storage_for_modules(void);
> > +extern unsigned long memory_for_modules(void);
> > +
> > +extern int print_module_debug_info(char *buffer, int buffer_size);
>
> Suspend prefix for the names of all of the above please? They're
> confusing with kernel/module.c now.

Fair enough. Will do.

> > +extern int suspend_register_module(struct suspend_module_ops *module);
> > +extern void suspend_unregister_module(struct suspend_module_ops
> > *module); +
> > +extern int suspend2_initialise_modules(int starting_cycle);
> > +extern void suspend2_cleanup_modules(int finishing_cycle);
> > +
> > +int suspend2_get_modules(void);
> > +void suspend2_put_modules(void);
>
> I think we can call these suspend_{get|set}_modules instead i.e.
> without the extra '2'.

I wanted to avoid confusion with similar routine names Pavel might use. For
example, he has a resume_setup and I have a resume2_setup.

> > +
> > +static inline void suspend_initialise_module_lists(void) {
> > + INIT_LIST_HEAD(&suspend_filters);
> > + INIT_LIST_HEAD(&suspend_writers);
> > + INIT_LIST_HEAD(&suspend_modules);
> > +}
>
> I couldn't find a user for this. I would imagine there's only one,
> though, and this should be inlined there?

Ok.

--
See our web page for Howtos, FAQs, the Wiki and mailing list info.
http://www.suspend2.net IRC: #suspend2 on Freenode
[unhandled content-type:application/pgp-signature]
\
 
 \ /
  Last update: 2006-02-01 22:36    [W:0.439 / U:0.080 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site