lkml.org 
[lkml]   [2024]   [Feb]   [26]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [PATCH] iommu/vt-d: Use kcalloc() instead of kzalloc()
From
On 2/12/24 1:51 AM, Erick Archer wrote:
> This is an effort to get rid of all multiplications from allocation
> functions in order to prevent integer overflows [1].
>
> Here the multiplication is obviously safe because DMAR_LATENCY_NUM
> is the number of latency types defined in the "latency_type" enum.
>
> enum latency_type {
> DMAR_LATENCY_INV_IOTLB = 0,
> DMAR_LATENCY_INV_DEVTLB,
> DMAR_LATENCY_INV_IEC,
> DMAR_LATENCY_PRQ,
> DMAR_LATENCY_NUM
> };
>
> However, using kcalloc() is more appropriate [2] and improves
> readability. This patch has no effect on runtime behavior.
>
> Link:https://github.com/KSPP/linux/issues/162 [1]
> Link:https://www.kernel.org/doc/html/next/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments [2]
> Signed-off-by: Erick Archer<erick.archer@gmx.com>
> ---
> drivers/iommu/intel/perf.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)

I have queued this patch for v6.9.

Best regards,
baolu

\
 
 \ /
  Last update: 2024-05-27 15:21    [W:0.744 / U:0.016 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site