lkml.org 
[lkml]   [2024]   [Feb]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [PATCH] drm/amd/display: Use kcalloc() instead of kzalloc()
From


On 1/28/24 02:04, Lenko Donchev wrote:
> We are trying to get rid of all multiplications from allocation
> functions to prevent integer overflows. Here the multiplication is
> obviously safe, but using kcalloc() is more appropriate and improves
> readability. This patch has no effect on runtime behavior.
>
> Link: https://www.kernel.org/doc/html/next/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments
> Link: https://github.com/KSPP/linux/issues/162
>
> Signed-off-by: Lenko Donchev <lenko.donchev@gmail.com>
> ---
> drivers/gpu/drm/amd/display/dc/link/protocols/link_dpcd.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/gpu/drm/amd/display/dc/link/protocols/link_dpcd.c b/drivers/gpu/drm/amd/display/dc/link/protocols/link_dpcd.c
> index 5c9a30211c10..b67cd78e7c58 100644
> --- a/drivers/gpu/drm/amd/display/dc/link/protocols/link_dpcd.c
> +++ b/drivers/gpu/drm/amd/display/dc/link/protocols/link_dpcd.c
> @@ -164,7 +164,7 @@ static void dpcd_extend_address_range(
> if (new_addr_range.start != in_address || new_addr_range.end != end_address) {
> *out_address = new_addr_range.start;
> *out_size = ADDRESS_RANGE_SIZE(new_addr_range.start, new_addr_range.end);
> - *out_data = kzalloc(*out_size * sizeof(**out_data), GFP_KERNEL);
> + *out_data = kcalloc(*out_size, sizeof(**out_data), GFP_KERNEL);
> }
> }
>

lgtm,

Reviewed-by: Rodrigo Siqueira <Rodrigo.Siqueira@amd.com>

\
 
 \ /
  Last update: 2024-05-27 15:15    [W:0.039 / U:0.364 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site