lkml.org 
[lkml]   [2024]   [Feb]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
Date
From
SubjectRe: [PATCH] mm/swapfile:__swap_duplicate: drop redundant WRITE_ONCE on swap_map for err cases
On Wed, 21 Feb 2024 22:10:28 +1300 Barry Song <21cnbao@gmail.com> wrote:

> From: Barry Song <v-songbaohua@oppo.com>
>
> The code is quite hard to read, we are still writing swap_map after
> errors happen. Though the written value is as before,
>
> has_cache = count & SWAP_HAS_CACHE;
> count &= ~SWAP_HAS_CACHE;
> [snipped]
> WRITE_ONCE(p->swap_map[offset], count | has_cache);
>
> It would be better to entirely drop the WRITE_ONCE for both
> performance and readability.
>
> ...
>
> --- a/mm/swapfile.c
> +++ b/mm/swapfile.c
> @@ -3320,6 +3320,9 @@ static int __swap_duplicate(swp_entry_t entry, unsigned char usage)
> } else
> err = -ENOENT; /* unused swap entry */
>
> + if (err)
> + goto unlock_out;
> +
> WRITE_ONCE(p->swap_map[offset], count | has_cache);
>
> unlock_out:

I agree, but why add the goto?

--- a/mm/swapfile.c~mm-swapfile-__swap_duplicate-drop-redundant-write_once-on-swap_map-for-err-cases-fix
+++ a/mm/swapfile.c
@@ -3335,10 +3335,8 @@ static int __swap_duplicate(swp_entry_t
} else
err = -ENOENT; /* unused swap entry */

- if (err)
- goto unlock_out;
-
- WRITE_ONCE(p->swap_map[offset], count | has_cache);
+ if (!err)
+ WRITE_ONCE(p->swap_map[offset], count | has_cache);

unlock_out:
unlock_cluster_or_swap_info(p, ci);
_

\
 
 \ /
  Last update: 2024-05-27 15:15    [W:0.055 / U:0.064 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site